Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78399 - gcj crashes whilst compiling
Summary: gcj crashes whilst compiling
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-22 11:43 UTC by Gary Benson
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-10-02 20:45:49 UTC


Attachments (Terms of Use)
File that causes the crash (deleted)
2002-11-22 11:45 UTC, Gary Benson
no flags Details

Description Gary Benson 2002-11-22 11:43:20 UTC
Description of Problem:
gcj crashes whilst compiling the attached file with the following message:

gcj -C --encoding=UTF-8 --classpath=./upstream/src/java -d upstream/src/java
upstream/src/java/org/apache/commons/collections/DoubleOrderedMap.java
upstream/src/java/org/apache/commons/collections/DoubleOrderedMap.java: In class
`org.apache.commons.collections.DoubleOrderedMap$11':
upstream/src/java/org/apache/commons/collections/DoubleOrderedMap.java: In
method `access$0(org.apache.commons.collections.DoubleOrderedMap$11)':
upstream/src/java/org/apache/commons/collections/DoubleOrderedMap.java:0:
Internal compiler error in generate_bytecode_insns, at java/jcf-write.c:1850
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.

Version-Release number of selected component (if applicable):
gcc-java-3.2-7

How Reproducible:
ALways

Steps to Reproduce:
1. compile the attached file
2. see the message

Comment 1 Gary Benson 2002-11-22 11:45:59 UTC
Created attachment 86024 [details]
File that causes the crash

Comment 2 Gary Benson 2002-11-28 12:51:39 UTC
I filed this in Gnats (8741) since that's probably a better place for it.

http://gcc.gnu.org/cgi-bin/gnatsweb.pl?cmd=view%20audit-trail&database=gcc&pr=8741


Note You need to log in before you can comment on or make changes to this bug.