Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78392 - screen destroys layout of man
Summary: screen destroys layout of man
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: screen
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Lon Hohberger
QA Contact: Brock Organ
URL:
Whiteboard:
: 75914 79099 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-22 05:14 UTC by Clemens Schwaighofer
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-12-16 21:30:45 UTC


Attachments (Terms of Use)

Description Clemens Schwaighofer 2002-11-22 05:14:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2b) Gecko/20021016

Description of problem:
if you call man <prg> in screen it destroys the layout of the man page and makes
it unreadable. testet on a 1024x768 fb and via a ssh session.
lynx or pine for example work ...

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. screen
2. man screen

or

1. screen man screen
	

Actual Results:  you will see a mangled man page unable to proper scroll up and
down, not correct line breaks, etc

Expected Results:  a normal formated man page, like you see when you don't use
screen

Additional info:

it doesn't happen on 7.3.94 beta

Comment 1 Lon Hohberger 2002-11-22 14:53:15 UTC
Screen's UTF-8 support does not work properly, and so we removed it from 8.0. 
As you can see if you type 'set', LANG generally is "en_US.UTF-8", which causes
the problems you are seeing.

export LANG=en_US 

at the end of ~/.bashrc - this should cause the problem to go away.

Comment 2 Lon Hohberger 2002-12-05 21:04:58 UTC
Going to evaluate screen-3.9.13 to see if the UTF-8 problems have been fixed
(thus, allowing us to include UTF-8 support again).

Comment 3 Lon Hohberger 2002-12-05 21:05:13 UTC
*** Bug 79099 has been marked as a duplicate of this bug. ***

Comment 4 Lon Hohberger 2002-12-05 21:06:58 UTC
*** Bug 75914 has been marked as a duplicate of this bug. ***

Comment 5 Lon Hohberger 2002-12-05 21:21:16 UTC
3.9.13 looks promising.  It seems to fix the bug (see #65344) which caused us to
remove UTF-8 support in the first place.

Comment 6 Clemens Schwaighofer 2002-12-11 07:43:04 UTC
just when will it be in rawhide ? or in updates for 8.0 ... cause I think
without utf8 things like mc, ntsysv and other ncurses based stuff behave a bit
strange and are actually unusable.

Comment 7 Lon Hohberger 2002-12-11 14:37:51 UTC
I'm not sure.  For now, you can grab it from:

http://people.redhat.com/lhh/screen-3.9.13-2.i386.rpm

Since it's not a released version yet, hold off on filing bugs until it makes it
into (at least) rawhide.

Comment 8 Lon Hohberger 2002-12-16 21:30:45 UTC
3.9.13-2 is now in rawhide:

ftp://ftp.redhat.com/pub/redhat/linux/rawhide/i386/RedHat/RPMS/screen-3.9.13-2.i386.rpm

Internal testing reports that this fixes the problem.  Reopen if it is still broken.




Note You need to log in before you can comment on or make changes to this bug.