Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 7839 - default Xmodmap messes up backspace for VNC
Summary: default Xmodmap messes up backspace for VNC
Keywords:
Status: CLOSED DUPLICATE of bug 7841
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: xinitrc
Version: 6.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-12-16 12:52 UTC by Marko Macek
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-01-14 16:49:01 UTC


Attachments (Terms of Use)

Description Marko Macek 1999-12-16 12:52:37 UTC
The default Xmodmap should not contain a workaround for XFree86
backspace bug. The bug should be fixed in the X server (it's a one line
fix).

Messing with backspace causes keyboard to misbehave when vnc is used due to
differring keycodes (character '5' doesn't work).

Comment 1 Preston Brown 2000-01-14 16:47:59 UTC
what is your proposed fix?

Without this Xmodmap, and if you aren't using xkb extensions, motif apps have
backspace problems.

Comment 2 Preston Brown 2000-01-14 16:49:59 UTC
*** This bug has been marked as a duplicate of 7841 ***

Comment 3 Marko Macek 2000-01-14 17:02:59 UTC
The proposed fix is in the bug#7841 as you have noticed.


Note You need to log in before you can comment on or make changes to this bug.