Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78368 - Galeon/Mozilla Seg fault when printing a certain page
Summary: Galeon/Mozilla Seg fault when printing a certain page
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: galeon
Version: 8.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Christopher Blizzard
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-21 20:10 UTC by Tom Cross
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-07-22 20:31:20 UTC


Attachments (Terms of Use)
The webpage in question that crashed mozilla/galeon when printed (deleted)
2002-11-21 20:11 UTC, Tom Cross
no flags Details

Description Tom Cross 2002-11-21 20:10:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [en] (X11; U; Linux 2.4.18-10 i686)

Description of problem:
Trying to print a certain internal webpage and it crashed both galeon and mozilla.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Goto page in question
2.Click File->Print, click Print button
3.Crash (segmentation fault)
	

Actual Results:  Crash (segmentation Fault)

Expected Results:  Print the page.

Additional info:

Actually tried it on two different systems, both RedHat 8.0 and it crashed
mozilla & galeon on both machines.

Both machines have the following packages:

mozilla-1.0.1-26
galeon-1.2.6-0.8.0
kernel-2.4.18-18.8.0

Comment 1 Tom Cross 2002-11-21 20:11:20 UTC
Created attachment 85948 [details]
The webpage in question that crashed mozilla/galeon when printed

Comment 2 Tom Cross 2002-11-21 20:14:46 UTC
The page in question works fine on a RedHat 7.3 with the following versions:

mozilla-1.0.0-5.ximian.1
galeon-1.2.5-2.ximian.3

Comment 3 Michael Lee Yohe 2002-11-22 00:27:37 UTC
Confirming.. it also blows up my machine.

$ rpm -q mozilla
mozilla-1.0.1-26
$ rpm -q galeon
galeon-1.2.6-0.8.0

This should not be a galeon bug, however - since the Mozilla renderer is the
thing that crashes.

Comment 4 Tom Cross 2004-07-09 15:47:49 UTC
Can we close this bug?  This problem has been fixed with newer
galeon/mozilla...

Comment 5 Christopher Blizzard 2004-07-22 20:31:20 UTC
Marking CURRENTRELEASE.


Note You need to log in before you can comment on or make changes to this bug.