Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78360 - httpd won't start after kernel errata upgrade
Summary: httpd won't start after kernel errata upgrade
Keywords:
Status: CLOSED DUPLICATE of bug 74543
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: apache
Version: 7.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-21 18:22 UTC by Need Real Name
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:11 UTC


Attachments (Terms of Use)

Description Need Real Name 2002-11-21 18:22:46 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.0.0; Linux)

Description of problem:
After upgrading our kickstart RPMs to include the new kernel errata rpm (kernel-2.4.18-17.7.x), we are seeing the following error when restarting httpd on boxes kicked with this config:
[Wed Nov 20 16:37:19 2002] [error] mod_ssl: Cannot allocate shared memory: mm:core: failed to acquire semaphore (No space left on device)

Perhaps this is related to bug 78019.  Seems similar but not exactly.  It appears that some process is leaking sempahores.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. Kick system with kernel-2.4.18-17.7.x, apache, apache-1.3.22-7, mod_ssl-2.8.5-6, php-4.1.2-7.2.6, postgresql-7.2.1-5
2. Use sqlrelay (from firstworks.com) to broker php's database requests
3. Allow httpd server to run for a while and service many PHP database releated requests (suggest using siege or something similar to inflate the number of requests quickly)
4. Restart apache via apachectl restart
 

Actual Results:  The system appears to be out of sempahores for some reason and yields the following error in the apache error_log:

[Wed Nov 20 16:37:19 2002] [error] mod_ssl: Cannot allocate shared memory: mm:core: failed to acquire semaphore (No space left on device)


Expected Results:  Apache gracefully restarts.

Additional info:

If I can find a way to 100% reproduce the problem I will update the bug later this week or next.  Thanks for any light shed on the problem.

Comment 1 Joe Orton 2003-04-03 15:36:18 UTC
This was probably the mm bug, and should have been fixed by:

http://rhn.redhat.com/errata/RHBA-2002-273.html


*** This bug has been marked as a duplicate of 74543 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:50:11 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.