Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78350 - vim won't die
Summary: vim won't die
Keywords:
Status: CLOSED DUPLICATE of bug 83700
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnome-core
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-21 17:07 UTC by Steve Dum
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:11 UTC


Attachments (Terms of Use)

Description Steve Dum 2002-11-21 17:07:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020827

Description of problem:
Vim sessions active when logging out don't die.  (I assume gnome isn't
passing a hup to the session).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Start up gnome
2.in a xterm run vim
3.logout without first exiting from vim.

	

Actual Results:  the vim session, not only doesn't die but it goes into an
infinite loop pegging the cpu

Expected Results:  vim should have died.  Either by getting a hup from the
shutdown or
by detecting that it's stdin has been closed, or both.

Additional info:

Comment 1 Karsten Hopp 2002-12-03 09:07:01 UTC
It gets the correct signal with KDE and aborts. It seems than gnome doesn't pass
the right signal.
Changing component to gnome

Comment 2 Karsten Hopp 2003-06-20 11:51:40 UTC

*** This bug has been marked as a duplicate of 83700 ***

Comment 3 Red Hat Bugzilla 2006-02-21 18:50:11 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.