Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78346 - (G400) Xinerama - getting sporatic text on wrong monitor
Summary: (G400) Xinerama - getting sporatic text on wrong monitor
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: Jay Turner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-21 16:49 UTC by Ray Parish
Modified: 2015-01-08 00:01 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-12-17 22:06:43 UTC


Attachments (Terms of Use)
Notice on the right side of the screen under the kernel compilation, is some text (deleted)
2002-11-21 16:50 UTC, Ray Parish
no flags Details
My XF86config (deleted)
2002-11-25 15:14 UTC, Ray Parish
no flags Details
lspci -vvn output (deleted)
2002-11-25 19:24 UTC, Ray Parish
no flags Details

Description Ray Parish 2002-11-21 16:49:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
I am using a dual monitor setup G400 Matrox card. Using Left monitor (main) and
bring up any type of program, i get some text from the program on the right
monitor. This happens in KDE as well

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install 8.0
2.configure X to use xinerama 
3.Open programs and use them
	

Actual Results:  Get text on other screen

Expected Results:  No text on other screen

Additional info:

Comment 1 Ray Parish 2002-11-21 16:50:43 UTC
Created attachment 85924 [details]
Notice on the right side of the screen under the kernel compilation, is some text

Comment 2 Havoc Pennington 2002-11-21 17:07:22 UTC
This is an mga driver bug, you can work around by adding 
Option "XaaNoScreenToScreenCopy" to Section "Device" in your
XF86Config, though that makes things a bit slow.

Comment 3 Mike A. Harris 2002-11-24 05:30:00 UTC
Please attach your XFree86 config, log file, and /var/log/messages as
individual uncompressed file attachments using the link below.

Also the output of:  lspci -vvn

TIA

Comment 4 Mike A. Harris 2002-11-24 09:23:37 UTC
Please download and test the following driver:

Rename your existing driver /usr/X11R6/lib/modules/drivers/mga_drv.o
to mga_drv.o.orig first, then put the new one in place. Then edit
your config file, and remove any options that disable acceleration, 
etc.

ftp://people.redhat.com/mharris/test-drivers/mga_drv.o

Test it fully until you are sure it works or does not work.  Once I've
gotten feedback from that, I can explore the problem deeper, and try
to possibly fix the root cause



Comment 5 Ray Parish 2002-11-25 15:13:41 UTC
Tried the above mentioned driver but Xinerama didn't kick the 2nd monitor up
online? Does that driver support Xinerama?


Comment 6 Ray Parish 2002-11-25 15:14:37 UTC
Created attachment 86324 [details]
My XF86config

Comment 7 Ray Parish 2002-11-25 19:24:07 UTC
Created attachment 86384 [details]
lspci -vvn output

Comment 8 Mike A. Harris 2002-12-17 22:06:43 UTC
Red Hat Linux does not support dualhead on G400.  You are using Matrox's
binary hallib which is unsupported by Red Hat.

This issue has been resolved in rawhide, but it will be unuseable to you
as you require Matrox's binary hallib which we do not support.  G450 and
G550 users will note the problem which affects all 3 cards is fixed in
rawhide now.

XFree86 build 4.2.99.2-20021217


Note You need to log in before you can comment on or make changes to this bug.