Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78344 - "jumps" while selecting item in list widget with scrollbar
Summary: "jumps" while selecting item in list widget with scrollbar
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-21 16:26 UTC by Leonid Kanter
Modified: 2015-01-04 22:02 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-11-27 23:09:35 UTC


Attachments (Terms of Use)

Description Leonid Kanter 2002-11-21 16:26:08 UTC
Description of Problem: 
 
When I select language from language list, or package from packages list, 
unexpected list scroll is performed. 
 
Version-Release number of selected component (if applicable): 
 
8.0.90 installer 
 
How Reproducible: 
 
always 
 
Additional Information: 
 
My mouse is logitech mouseman+ (ps/2)

Comment 1 Matt Wilson 2002-11-22 02:45:03 UTC
it should only "jump" if the item you are clicking on is not completely visible.
 Is the item you are clicking on totally visible?  (not cut off at the top or
bottom due to the scrolled window)


Comment 2 Leonid Kanter 2002-11-22 11:37:55 UTC
Not, it jumps even if item (i.e. Russian in langs list) is third from bottom.
But I'm unable to reproduce this with USB mouse. Looks like something is wrong
with ps/2 driver because I see random jumps even in Gnome after installation
(while moving window, it can jump to other side of screen). PS/2 mouse itself is
OK, if I boot RH8 on the same box.

Comment 3 Leonid Kanter 2002-11-22 16:32:12 UTC
on my box 8.0.90 installer is unable to detect serial mouse
(Logitech M-S48 "mouseman+" serial).  It proposes to select mouse type
from list,  but I'm unable to do it because keyboard controller become
completely frozen! If I boot RH8 installer on the same hardware -
everything is OK. 

I have 8.0.90 already installed and configured for PS/2 mouse on
this box. I saw problems during installation (bug 78344), and also
problems in GNOME (looks like ps/2 mouse is sending more events than
needed, so I have window jumps while moving etc). If I pull ps/2 mouse
off, connect serial mouse and reboot box, kudsu detect mouse change and
propose to reconfigure, but it's impossible to do it because keyboard
doesn't respond! BTW, after kudzu timeout it start responding again.


Comment 4 Eugene Kanter 2002-11-27 18:41:28 UTC
I have PS/2 mouse and the list did not jump when I clicked on Russian. Screen
was in 1024x768, I think.

Comment 5 Eugene Kanter 2002-11-28 23:12:22 UTC
The first language selection dialog is OK, but the second one does jump. Selected 
language is in the middle before the click. After the click it jumps so it is not visible.

Comment 6 Alan Cox 2003-06-05 12:57:24 UTC
Appears to be another variant of the XFree86 duplicate key/event bug ?



Note You need to log in before you can comment on or make changes to this bug.