Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 7832 - multiple copies print when only one wanted
Summary: multiple copies print when only one wanted
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: lpr
Version: 6.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-12-16 05:34 UTC by rgolan
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-01-14 21:36:34 UTC


Attachments (Terms of Use)

Description rgolan 1999-12-16 05:34:03 UTC
I'm using rhs-printfilters-1.58-1.i386.rpm from rawhide and
lpr-0.46-1.i386.rpm on a print/file server. When one of the client Macs
prints multiple copies of a document, all subsequent print jobs print the
same number of copies until the printer is reset. Printer is a HP LaserJet
4m (postscript) attached to the print server through the parallel port.
When a multi copy text file print job is generated on the print server
itself (via lpr), subsequent single page jobs print the correct number of
pages. The Macs print to the LJ4m through the Macs' LPR desktop printing
facility. No appletalk in involved. This printer and server worked properly
under RH 5.2. Nothing in the Macs has changed.

I have an HP postscript plotter also on the network as a remote printer and
it works correctly with regard to number of copies.

Can't figure out if problem is in printfilters, lpr or flakey printer.

Comment 1 Bernhard Rosenkraenzer 1999-12-17 15:30:59 UTC
It would appear to be a printer problem, as I can't reproduce it here on a
Lexmark 3000 Color Jetprinter (which doesn't do hardware multi-printing).
I'll have to check if I can reproduce it on other printers that support
multi-printing.

Comment 2 rgolan 2000-01-14 21:36:59 UTC
I made some further tests. It appears the problem is coming from the Macs which
are using MacOS 8.1. I generated a postscript file on the Linux box using
cdlabelgen and printed two copies using lpr. ( lpr -#2 filename.ps ) Afterwards,
using lpr to print a single copy worked as expected. ( lpr filename.ps )

I think the Macs are sending something in the lpr print request that causes the
HP LJ4m to store the number of copies. Is there a way to capture the print
requests as sent from the Macs so I can see what is going on?

Comment 3 Bernhard Rosenkraenzer 2000-07-19 17:21:31 UTC
Please check if this still happens with LPRng (from rawhide).

Comment 4 rgolan 2000-08-06 23:00:56 UTC
I installed the following:

ftp://ftp.astart.com/pub/LPRng/LPRng/LPRng-3.6.22-1.i386.rpm
ftp://ftp.astart.com/pub/LPRng/FILTERS/ifhp-3.3.19-1.i386.rpm

and adjusted the printcap file to specify my printer model.

results:

fixed the multiple copy problem
fixed the incorrect paper tray selection problem (never reported)
fixed the hanging on printing of binary files (never reported)

hooray!

Not only did it fix those problems but now for each job, the user login and job
name are displayed on the little fluorescent panel on the printer.



Note You need to log in before you can comment on or make changes to this bug.