Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78270 - Static routes can't be set in /etc/sysconfig/static-routes as following the documentation
Summary: Static routes can't be set in /etc/sysconfig/static-routes as following the d...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-20 18:18 UTC by Lokhin
Modified: 2014-03-17 02:32 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-20 18:19:01 UTC


Attachments (Terms of Use)

Description Lokhin 2002-11-20 18:18:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ru-RU; rv:1.2b) Gecko/20021022

Description of problem:
Static routes can't be set in /etc/sysconfig/static-routes if following the
initscripts' documentation.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Read the /usr/share/doc/initscripts-6.95/sysconfig.txt file
2. Set a static route on a particular network interface in
/etc/sysconfig/static-routes
3. service network restart
4. netstat -nr
	

Actual Results:  No static route is set on a particular interface mentioned in
static-routes as 'eth1 net 172.16.6.0 netmask 255.255.255.0 gw 192.168.0.1 eth1'
or 'eth1 net 172.16.6.0 netmask 255.255.255.0 gw 192.168.0.1'.

Expected Results:  Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
172.16.6.0         192.168.0.1     255.255.255.0   UG       40 0          0 eth1

Additional info:

Documentation should be fixed since many people read it at first and then
configure their network settings. Didn't find any mention about
/etc/sysconfig/network-scripts/route-<DEV> in sysconfig.txt.

Comment 1 Bill Nottingham 2002-11-20 18:33:24 UTC
Documentation stuff fixed in the rawhide initscripts, along with some functionality.


Note You need to log in before you can comment on or make changes to this bug.