Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 7823 - trouble mounting XENIX filesystem
Summary: trouble mounting XENIX filesystem
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Pete Zaitcev
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-12-16 00:27 UTC by Stephen Duame
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-06-04 18:40:11 UTC


Attachments (Terms of Use)

Description Stephen Duame 1999-12-16 00:27:59 UTC
Date: 12-13-99
Problem: mounting XENIX partition

I have been unable to mount my XENIX partition.  I have an IDE HD with a
SCO XENIX 2.3.4 partition taking up the full disk (240MB).
If the XENIX HD is installed on the primary/master IDE it will boot and
run successfully.  If a fsck is run on the filesystem there are no errors.

On my Linux system I have a primary/master HD partitioned with win98 (2GB)
and Linux (8GB) and a CD on the secondary/master and everything works fine.
All attempts to mount the XENIX HD (secondary/slave) in the Linux system
have been unsuccessful.

Linux boot does recognize the XENIX HD (on hdd) as shown below:

# dmesg | grep hd

    ide0: BM-DMA at 0xf000-0xf007, BIOS settings: hda:pio, hdb:pio
    ide1: BM-DMA at 0xf008-0xf00f, BIOS settings: hdc:pio, hdd:pio
hda: WDC WD102BA, ATA DISK drive
hdc: 36X CD-ROM, ATAPI CDROM drive
hdd: QUANTUM LP240A GM240A01X, ATA DISK drive
hda: WDC WD102BA, 9779MB w/1961kB Cache, CHS=1246/255/63
hdd: QUANTUM LP240A GM240A01X, 234MB w/256kB Cache, CHS=723/13/51
hdc: ATAPI 24X CD-ROM drive, 128kB Cache
 hda: hda1 hda2 < hda5 hda6 hda7 >
 hdd: hdd4


and fdisk recognizes the XENIX partition hdd4:

# fdisk -l /dev/hdd

Disk /dev/hdd: 13 heads, 51 sectors, 723 cylinders
Units = cylinders of 663 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hdd4   *         1       722    239317+   2  XENIX root


XENIX is listed in the RedHat Linux 6.1 Reference Guide page 460
as a supported partiton type.  if I understand correctly, XENIX
has been merged into the Sys V loadable module (sysv).
But the mount command generates the error below:

# mount -t sysv /dev/hdd4 /mnt/sysv

VFS: unable to read Xenix/SystemV/Coherent superblock on device 16:44
mount: wrong fs type, bad option, bad superblock on /dev/hdd4,
       or too many mounted file systems

I spoke to Dave Cook at RedHat tech support, he was very knowledgeable
and we tried several things but to no avail.  He suggested I enter
a bugzilla report which I am doing now.  I hope you can help.

Stephen Duame
sduame@compuserve.com
954-456-4527

Comment 1 Bernhard Rosenkraenzer 1999-12-17 14:44:59 UTC
The mount command is correct, and mount seems to be doing the right thing.
Looks like a bug in sysv support in the kernel - reassigning.

Comment 2 Cristian Gafton 2000-01-04 22:26:59 UTC
Assigned to dledford

Comment 3 Brent R Brian 2000-01-05 16:47:59 UTC
I have the same, exact, problem. RH6.1 with Xenix 2.3.4,
same error message.

I am running ADM486-100, 64M RAM, FIC 486/PCI Motherboard.

Brent R Brian, Brian Enterprises
BrentRBrian@prodigy.net
704-868-2224

Comment 4 Pete Zaitcev 2002-06-04 18:40:05 UTC
Found this ancient bug in the Bugzilla cleanup, taking.
Is there an interest still? We are on release 7.2 now.
The last 6.x supported is 6.2.



Comment 5 Pete Zaitcev 2002-07-01 17:32:19 UTC
I spoke with sysv maintainer Christoph Hellwig (hch),
and he is generally available. Closing the bug as stale,
reopen if there's an actual interest and if a current
release can reproduce the problem. Then I'll take it up
with Christoph.


Note You need to log in before you can comment on or make changes to this bug.