Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78215 - php-snmp stops php page processing when accessing snmp functions
Summary: php-snmp stops php page processing when accessing snmp functions
Keywords:
Status: CLOSED DUPLICATE of bug 74761
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: php
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-20 05:13 UTC by Need Real Name
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:10 UTC


Attachments (Terms of Use)

Description Need Real Name 2002-11-20 05:13:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; Q312461; .NET 
CLR 1.0.3705)

Description of problem:
If a line like below is in the php page,
<?
$syscontact = snmpget("127.0.0.1", "public", "system.SysContact.0");
?> 
the page will stop being processed at that line, no errors are displayed, it's 
as if you were to have put in the word "end".  I believe this has something to 
do with the fact that net-snmp doesn't support some of the called ucd-snmp 
supported.  Furthermore, when making a snmp call to net-snmp based commands 
like snmpget, a -c is required to specify the community string unlike with ucd-
snmp.  I don't think it's related to the PHP problem, but a lot things were 
based off ucd-snmp and the php-snmp that is included will not install with ucd-
snmp 4.2.3 installed (via packages), it thinks they aren't there.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install a "vanilla" copy of RH 8
2. Install the php-snmp package
3. Make this simple php page and watch it not work:

//Begin Here
<html>
<body>
<?
echo "Hi";
$syscontact = snmpget("127.0.0.1", "public", "system.SysContact.0");
echo " there!";
?>
</body>
</html>


	

Actual Results:  You will just see a blank page with the word "Hi".

Expected Results:  I should have seen my name, or at least both Hi and there!

Additional info:

Comment 1 Need Real Name 2002-11-20 12:47:14 UTC
See #74761 bug!


Comment 2 Joe Orton 2003-02-12 16:10:30 UTC

*** This bug has been marked as a duplicate of 74761 ***

Comment 3 Red Hat Bugzilla 2006-02-21 18:50:10 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.