Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78202 - /etc/init.d/krb5kdc checks for hard coded file name
Summary: /etc/init.d/krb5kdc checks for hard coded file name
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: krb5
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-19 23:53 UTC by Jim Richardson
Modified: 2007-04-18 16:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-08-08 15:46:40 UTC


Attachments (Terms of Use)

Description Jim Richardson 2002-11-19 23:53:00 UTC
From Bugzilla Helper:
User-Agent: Opera/6.1 (Linux 2.4.18-18.8.0 i686; U)  [en]

Description of problem:
I followed the documented kerberos setup and created my database with a name that wasn't "prinicle". The init.d script checks for the existence of the "principle" file and exits if it doesn't exist. I simply touched a principle file in the correct location and the server seems to be working fine. Of course I am not sure YET how to verify that, since it is my first time to set it up. 

The kadmin script has the same issue.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Setup a new kerberos database named something besides "principle"
2.
3.
	

Actual Results:  The server silently refuses to start

Expected Results:  Expected it to at least error with a message if a sanity test failed. But it will need to be improved to awk out the principle(s) names and verify that at least one exsits. As I read the documentaion there could be more than one princilple database running on a system.

Additional info:

Comment 1 Bill Nottingham 2006-08-07 18:27:05 UTC
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
Please check if this issue is still present in a current Fedora Core
release. If so, please change the product and version to match, and
check the box indicating that the requested information has been
provided. Note that any bug still open against Red Hat Linux on will be
closed as 'CANTFIX' on September 30, 2006. Thanks again for your help.


Comment 2 Jim Richardson 2006-08-08 15:46:40 UTC
Well it is good to know that after all these years that have passed this bug 
report wasn't closed. I suppose ignoring issues until a product expires is 
better than just sweeping them under the rug. Regardless, I've long since 
given up on krb as I now try to adhere to the KISS principle.


Note You need to log in before you can comment on or make changes to this bug.