Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78195 - unresolved symbol in modules pcmcia 2.2.22-6.2.2
Summary: unresolved symbol in modules pcmcia 2.2.22-6.2.2
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 6.2
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
: 76886 78430 78754 82080 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-19 22:44 UTC by Robert Franchisseur
Modified: 2007-04-18 16:48 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-04-24 08:41:39 UTC


Attachments (Terms of Use)

Description Robert Franchisseur 2002-11-19 22:44:51 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.2.19-6.2.16 i686)

Description of problem:
after upgrading from 2.2.19-6.2.16 to 2.2.22-6.2.2 I have no network
I got the following
messages:

localhost pcmcia: Starting PCMCIA services:
Nov 19 22:30:18 localhost pcmcia:  modules
Nov 19 22:30:18 localhost pcmcia:
/lib/modules/2.2.22-6.2.2/pcmcia/pcmcia_core.o: 
Nov 19 22:30:18 localhost pcmcia: unresolved symbol request_mem_region
Nov 19 22:30:18 localhost pcmcia:
/lib/modules/2.2.22-6.2.2/pcmcia/pcmcia_core.o: unresolved symbol
release_mem_region
Nov 19 22:30:18 localhost pcmcia: /lib/modules/2.2.22-6.2.2/pcmcia/i82365.o:
unresolved symbol pci_set_power_state
Nov 19 22:30:18 localhost pcmcia: /lib/modules/2.2.22-6.2.2/pcmcia/i82365.o:
unresolved symbol pci_enable_device
Nov 19 22:30:18 localhost pcmcia: /lib/modules/2.2.22-6.2.2/pcmcia/i82365.o:
unresolved symbol unregister_ss_entry
Nov 19 22:30:18 localhost pcmcia: /lib/modules/2.2.22-6.2.2/pcmcia/i82365.o:
unresolved symbol pci_irq_mask
Nov 19 22:30:18 localhost pcmcia: /lib/modules/2.2.22-6.2.2/pcmcia/i82365.o:
unresolved symbol register_ss_entry
Nov 19 22:30:18 localhost pcmcia: /lib/modules/2.2.22-6.2.2/pcmcia/i82365.o:
unresolved symbol CardServices
Nov 19 22:30:18 localhost pcmcia: /lib/modules/2.2.22-6.2.2/pcmcia/ds.o: 
Nov 19 22:30:18 localhost pcmcia:  cardmgr.
Nov 19 22:30:18 localhost pcmcia: unresolved symbol proc_pccard
Nov 19 22:30:18 localhost pcmcia: /lib/modules/2.2.22-6.2.2/pcmcia/ds.o:
unresolved symbol CardServices
Nov 19 22:30:19 localhost cardmgr[430]: starting, version is 3.1.24
Nov 19 22:30:19 localhost rc: Starting pcmcia succeeded
Nov 19 22:30:19 localhost cardmgr[430]: no pcmcia driver in /proc/devices
Nov 19 22:30:19 localhost cardmgr[430]: exiting
Nov 19 22:30:22 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.upgrade to kernel 2.2.22-6.2.2
2.
3.
	

Actual Results:  I have no more network .

Additional info:

localhost pcmcia: Starting PCMCIA services:
Nov 19 22:30:18 localhost pcmcia:  modules
Nov 19 22:30:18 localhost pcmcia:
/lib/modules/2.2.22-6.2.2/pcmcia/pcmcia_core.o: 
Nov 19 22:30:18 localhost pcmcia: unresolved symbol request_mem_region
Nov 19 22:30:18 localhost pcmcia:
/lib/modules/2.2.22-6.2.2/pcmcia/pcmcia_core.o: unresolved symbol
release_mem_region
Nov 19 22:30:18 localhost pcmcia: /lib/modules/2.2.22-6.2.2/pcmcia/i82365.o:
unresolved symbol pci_set_power_state
Nov 19 22:30:18 localhost pcmcia: /lib/modules/2.2.22-6.2.2/pcmcia/i82365.o:
unresolved symbol pci_enable_device
Nov 19 22:30:18 localhost pcmcia: /lib/modules/2.2.22-6.2.2/pcmcia/i82365.o:
unresolved symbol unregister_ss_entry
Nov 19 22:30:18 localhost pcmcia: /lib/modules/2.2.22-6.2.2/pcmcia/i82365.o:
unresolved symbol pci_irq_mask
Nov 19 22:30:18 localhost pcmcia: /lib/modules/2.2.22-6.2.2/pcmcia/i82365.o:
unresolved symbol register_ss_entry
Nov 19 22:30:18 localhost pcmcia: /lib/modules/2.2.22-6.2.2/pcmcia/i82365.o:
unresolved symbol CardServices
Nov 19 22:30:18 localhost pcmcia: /lib/modules/2.2.22-6.2.2/pcmcia/ds.o: 
Nov 19 22:30:18 localhost pcmcia:  cardmgr.
Nov 19 22:30:18 localhost pcmcia: unresolved symbol proc_pccard
Nov 19 22:30:18 localhost pcmcia: /lib/modules/2.2.22-6.2.2/pcmcia/ds.o:
unresolved symbol CardServices
Nov 19 22:30:19 localhost cardmgr[430]: starting, version is 3.1.24
Nov 19 22:30:19 localhost rc: Starting pcmcia succeeded
Nov 19 22:30:19 localhost cardmgr[430]: no pcmcia driver in /proc/devices
Nov 19 22:30:19 localhost cardmgr[430]: exiting
Nov 19 22:30:22

Comment 1 giulioo 2002-11-23 07:56:41 UTC
*** Bug 78430 has been marked as a duplicate of this bug. ***

Comment 2 westfahl 2002-12-01 16:39:22 UTC
The same problem exists in kernel-2.2.22-6.2.3


Comment 3 westfahl 2002-12-01 16:41:04 UTC
The same problem exists in kernel-2.2.22-6.2.3


Comment 4 giulioo 2003-01-19 16:47:36 UTC
*** Bug 78754 has been marked as a duplicate of this bug. ***

Comment 5 giulioo 2003-01-19 16:48:12 UTC
*** Bug 82080 has been marked as a duplicate of this bug. ***

Comment 6 giulioo 2003-01-19 16:49:16 UTC
*** Bug 76886 has been marked as a duplicate of this bug. ***

Comment 7 simon.greaves 2003-04-23 21:56:57 UTC
5 months on, no change in status.. Is this going to get fixed?


Comment 8 acount closed by user 2003-04-23 23:27:06 UTC
6.2 is out of maintenance:
http://lwn.net/Articles/27600/

Comment 9 Robert Franchisseur 2003-04-24 00:29:08 UTC
It has been solved in kernel 2.2.24-6.2.3
see
https://rhn.redhat.com/network/errata/details/package_list.pxt?eid=1544

Comment 10 Arjan van de Ven 2003-04-24 08:41:39 UTC
it's fixed in the current, final erratum.


Note You need to log in before you can comment on or make changes to this bug.