Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78186 - gcc gives seg fault when compiling the file Prova.c
Summary: gcc gives seg fault when compiling the file Prova.c
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc
Version: 7.3
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL: www.speech.kth.se/~giampi/Prova.c
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-19 21:10 UTC by Giampiero Salvi
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-20 08:57:23 UTC


Attachments (Terms of Use)

Description Giampiero Salvi 2002-11-19 21:10:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4) Gecko/20011019
Netscape6/6.2

Description of problem:
I run gcc Prova.c and get:
--
cc1: Internal error: Segmentation fault.
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
--

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.gcc Prova.c
	

Actual Results:  cc1: Internal error: Segmentation fault.
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.


Expected Results:  it should have compiled the program

Additional info:

Comment 1 Giampiero Salvi 2002-11-20 08:57:17 UTC
It seems that the behaviour I got was due to temporal instability of the 
system. I tried to compile a "Hello world!" c program and I got the same 
result. When I rebooted the machine the problem was fixed.

I wander if the instability could have been caused by running the Prova.c 
program: in the beginning I could compile it an run it. After several small 
modifications (I recompiled it maybe 10-20 times) I started to get that 
problem.

Hope this helps. Giampiero

Comment 2 Jakub Jelinek 2002-11-20 09:09:04 UTC
Then definitely it has nothing to do with gcc compiler.
It can be either most probably either hardware fault or kernel fault.


Note You need to log in before you can comment on or make changes to this bug.