Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78166 - New SMP kernels crash on Del servers
Summary: New SMP kernels crash on Del servers
Keywords:
Status: CLOSED DUPLICATE of bug 69920
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 7.3
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeff Garzik
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-19 16:56 UTC by Need Real Name
Modified: 2013-07-03 02:08 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-22 21:16:37 UTC


Attachments (Terms of Use)

Description Need Real Name 2002-11-19 16:56:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.1)
Gecko/20020823 Netscape/7.0

Description of problem:
The 2.4.18-10SMP kernel seems to be the last stable 7.3 kernel that runs on a
Del PowerEdge 2550 (dual CPU) or Del PowerEdge 6450 (quad CPU). The
2.4.18-17.7.xsmp and 2.4.18-18.7.xsmp kernels both crash on both models after
running for only 3-15 hours.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot with 2.4.18-17.7.xsmp or 2.4.18-18.7.xsmp kernel
2. Run for 3-15 hours
3. System locks up and stops running with no error log written into anything in
/var/log that I can find
	

Additional info:

Comment 1 Need Real Name 2002-11-19 19:04:32 UTC
I am experiencing this exact problem on a Dell PowerEdge 2550.

7.3 with all applicable latest packages and the 2.4.18-17.7.x-smp and 2.4.18-
18.7.x-smp both lock up the machine.   

My timeframes are 2-12 hours.   I have yet to maintain a system beyond about 12 
hours.

This machine uses ext3 and the tg3 gigabit ethernet card.

System locks hard, no oops / log messages.

I would be delighted to provide more troubleshooting/testing as required.  
Untill then I will be attempting to use the 2.4.18-10smp kernel as mentioned by 
wimple@ecs.csus.edu

Comment 2 Josko Plazonic 2002-11-22 21:16:27 UTC
I would look into tg3 driver as possible problem.  I have a Dell 2650 with tg3
card with 2.4.18-17.7.x-smp modified by me to use the old 0.99 tg3 driver and it
has been stable so far (knock on wood) - 13 days so far, and with the normal
2.4.18-17.7.x-smp I was getting frequent kernel opses in tg3 driver.  Though I
do have to say that even with 0.99 I had serious NFS problems when tg3 was
operating at gigabit (can't talk to nfs server...), at 100Mb with rather heavy
traffic it is rock stable.

Comment 3 Jeff Garzik 2002-11-25 15:26:26 UTC
Please test the patch attached in bug 69920.


*** This bug has been marked as a duplicate of 69920 ***


Note You need to log in before you can comment on or make changes to this bug.