Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78134 - Apache using up semaphores without clearing previous disused semaphores
Summary: Apache using up semaphores without clearing previous disused semaphores
Keywords:
Status: CLOSED DUPLICATE of bug 74543
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: apache
Version: 7.3
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-19 11:31 UTC by Caniffe
Modified: 2007-04-18 16:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:10 UTC


Attachments (Terms of Use)
Semaphore List - Before Apache Restart (deleted)
2002-11-19 11:33 UTC, Caniffe
no flags Details
Semaphore List - Post Apache Restart (deleted)
2002-11-19 11:34 UTC, Caniffe
no flags Details

Description Caniffe 2002-11-19 11:31:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
When restarting Apache 7.3 w/mod_frontpage, apache boots as normal but creates 
an additional two semaphore arrays without clearing or deleting the old ones.  
This poses a problem when apache is restarted thus 64 times, then reaching the 
128 semaphore array "normal" limit.  Compiling the apache source and 
integrating php+mysql+mod_frontpage without using RedHat RPMs does not stack 
up on semaphores.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install RH 7.3, Apache with PHP + MySQL.
2. Install mod_frontpage 1.6.2+
3. Restart Apache
	

Actual Results:  An additional two semaphore arrays are created, leaving 
redundant semaphores in memory.

Expected Results:  Apache should by nature, delete unused semaphore arrays.

Additional info:

Packages:
apache-1.3.23-14
apache-devel-1.3.23-14
php-4.1.2-7.3.6
php-mysql-4.1.2-7.3.6
mysql-3.23.49-3
mod_frontpage_mirfak-1.6.2 (external package)
Unix Frontpage Extensions 5.0

Comment 1 Caniffe 2002-11-19 11:33:25 UTC
Created attachment 85546 [details]
Semaphore List - Before Apache Restart

Comment 2 Caniffe 2002-11-19 11:34:08 UTC
Created attachment 85547 [details]
Semaphore List - Post Apache Restart

Comment 3 Caniffe 2002-12-17 12:18:32 UTC
This problem is thankfully rectified via the following errata:

Summary:
Updated mm packages available
Bug Fix Advisory - RHBA-2002:273-09
https://rhn.redhat.com/network/errata/errata_details.pxt?eid=1355

*** This bug has been marked as a duplicate of 74543 ***

Comment 4 Red Hat Bugzilla 2006-02-21 18:50:10 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.