Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78124 - Bad behaviour when selecting "everything"
Summary: Bad behaviour when selecting "everything"
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-19 09:27 UTC by jfm2
Modified: 2007-04-18 16:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-19 18:29:45 UTC


Attachments (Terms of Use)

Description jfm2 2002-11-19 09:27:42 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
I use to select "everything" when installing but I certainly don't mean
manpages, fonts and software intended for languages I didn't select in the list
and I don't read.  It is still more aggarvating because  the new graphical
package tool does not allow to uninstall fonts.

IMHO correct behaviour should be to install only the docs, fonts and linguistic
software needed for selected languages by the user (plus those for US english
since there is muvh unstranslated software) not chinese fonts, russian manpages
and fidjian KDE docs.

Alternatively: prompt the user if he has selected "everything"

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install and select "verything"
2.
3.
	

Additional info:

Comment 1 Jeremy Katz 2002-11-19 19:48:05 UTC
No, everything means (according to the Merriam Webster dictionary) "all that
exists".  Everything doesn't mean "everything except these certain things that I
don't think count as everything."

Comment 2 jfm2 2002-11-19 20:19:38 UTC
Webster could tell that but books about economy and business tell that if
customers tell that "everything" means "software plus only docs and fonts needed
for the languages they selected and not Chinese or Fidjian" then customers are
right and Webster is wrong. Webster does't back its opinions with $$.  And BTW I
bought a copy of Psyche.  

I select everything for one reason: when I compile a piece of software, autoconf
will try to autodetect required components needed for the build.  If something
is missing either the build will fail or still worse it will silently discard
that functionality and I will get a crippled piece of software.  For instance if
png-devel is not installed I could get a Gimp who does not handle PNGs. 
Installing everything has an additional benefit: I get reproducible builds.  But
I <b>don't</b> want chinese fonts or man pages in Czech.   If it were easy to
uninstall them then problem would be less annoying but in RedHat 8.0 the graphic
tool quite simply doesn't show those font and doc packages so finding them and
uninstalling them is painful. 

Now what you have to decide for next  version of Anaconda is not what webster
says but if there are more people with $$ in hand who think like you "everything
means the kitchen sink too" or like me "Everything does not include docs and
fonts for languages I didn't select bexcause I cannot read them".  The side with
more $$ wins.

Comment 3 Michael Fulbright 2002-12-20 17:38:25 UTC
Time tracking values updated


Note You need to log in before you can comment on or make changes to this bug.