Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78106 - etags should be a package of its own
Summary: etags should be a package of its own
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: xemacs
Version: 7.3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jens Petersen
QA Contact: Jay Turner
URL:
Whiteboard:
: 78668 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-19 04:37 UTC by Ben Woodard
Modified: 2015-01-08 00:01 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-05-19 08:40:26 UTC


Attachments (Terms of Use)

Description Ben Woodard 2002-11-19 04:37:11 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
You should either include etags with xemacs or make etags a package of its own.
The way that it is now, even if you only use xemacs if you need etags, you have
to install emacs.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.don't install emacs
2.install xemacs
3.try to run etags
	

Actual Results:  command not found

Expected Results:  etags runs.

Additional info:

Comment 1 Jens Petersen 2002-11-28 05:53:49 UTC
*** Bug 78668 has been marked as a duplicate of this bug. ***

Comment 2 Jens Petersen 2002-11-28 05:58:53 UTC
Thanks for reminding me about this. :)

BTW ctags is actually a separate upstream package.

What I'm thinking now, is for the time being at least is to ship etags with
XEmacs named as etags.xemacs, and symlink it to etags at install time if 
there is no etags installed.  Perhaps I will do the same with Emacs later.
Then alternatives could also be used to choose one or the other when both
are installed.

Comment 3 Jens Petersen 2002-11-28 06:00:53 UTC
(moving to xemacs component)

Comment 4 Jens Petersen 2002-12-23 17:04:49 UTC
xemacs-21.4.10-5 should have etags.emacs.
Please confirm.

Comment 5 Ben Woodard 2002-12-23 17:22:09 UTC
I'd say yes. Please either include etags with xemacs or make an additional
package which has etags from emacs in it and allow it to be installed seperately.

-ben

Comment 6 Jens Petersen 2003-01-02 00:18:06 UTC
I mean it includes "/usr/bin/etags.xemacs".


Note You need to log in before you can comment on or make changes to this bug.