Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78100 - hw browser crashes
Summary: hw browser crashes
Keywords:
Status: CLOSED DUPLICATE of bug 74956
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: hwbrowser
Version: 8.0
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
: 81339 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-19 01:53 UTC by Need Real Name
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:10 UTC


Attachments (Terms of Use)

Description Need Real Name 2002-11-19 01:53:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
(DeviceList.py:14659): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c:
line 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.start from menu or terminal
2.blank screen appears for a moment then disappears
3.then nothing
	

Additional info:

Comment 1 Jonathan Blandford 2002-11-19 02:44:09 UTC
Can you run it from a terminal and paste any backtraces you might get?

Comment 2 Need Real Name 2002-11-22 12:41:44 UTC
[dbagn@localhost dbagn]$ hwbrowser

(DeviceList.py:10629): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c:
line 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:10629): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c:
line 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:10629): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c:
line 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:10629): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c:
line 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:10629): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c:
line 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:10629): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c:
line 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:10629): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c:
line 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:10629): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c:
line 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed
Traceback (most recent call last):
  File "/usr/share/hwbrowser/DeviceList.py", line 203, in ?
    reread_device_type_list ()
  File "/usr/share/hwbrowser/DeviceList.py", line 150, in reread_device_type_list
    list.set (iter, 0, hardware.get_category_string (key), 1, key)
  File "/usr/share/hwbrowser/DeviceList.py", line 91, in get_category_string
    return self.type_mapping[key]
KeyError: 20
[dbagn@localhost dbagn]$


Comment 3 Need Real Name 2002-12-04 03:44:52 UTC
Do I need to post anything else or is there not a solution available?



Comment 4 Nick Dimiduk 2002-12-11 09:12:32 UTC
I get this same error.  I believe upon installing RH8.0 on my system, I recall
seeing something about a similar "assertion 'PATH != NULL' failed" warning
(error?) after the installation had completed and the X server was terminated. 
I tryed re-installing and recieved the same error, same problem with hwbrowser.
 If there's anything I can add aid this bug fix (I realize it's not a high
priority based on the number of results which came up in my search).
Thanks,
-nd

Comment 5 Brent Fox 2003-01-08 16:16:44 UTC
*** Bug 81339 has been marked as a duplicate of this bug. ***

Comment 6 Brent Fox 2003-01-08 23:02:36 UTC

*** This bug has been marked as a duplicate of 74956 ***

Comment 7 Red Hat Bugzilla 2006-02-21 18:50:10 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.