Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78097 - dhcpcd missing from RH8; dhclient hardcoded into networking scripts
Summary: dhcpcd missing from RH8; dhclient hardcoded into networking scripts
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: dhcpcd
Version: 8.0
Hardware: i586
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Elliot Lee
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-19 00:18 UTC by Need Real Name
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-19 00:18:37 UTC


Attachments (Terms of Use)

Description Need Real Name 2002-11-19 00:18:30 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021108

Description of problem:
The package for dhcpcd is missing from RH8. It appears someone at RedHat has
decided that dhclient will be the only dhcp client software used in RH8 and as a
result dhclient is hardcoded into the networking scripts. For previous RedHat
users with dhcp connections managed by dhcpcd this means that they either have
to write new dhcp scripts or try to migrate the dhcpcd integrated networking
scripts from a prior version. Note that removing the dhclient package with "rpm
-e" does not result in clean (dhcp neutral) networking scripts as hardcoded
references to dhclient still remain. If dhcpcd was previously used the user
should have the choice of installing networking scripts using dhcpcd or at least
scripts that are "dhcp neutral" so that adding dhcp client software isn't a chore.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Fundamental RH networking configuration problem.
	

Actual Results:  Existing iptables scripts cannot be run because the lease data
required for iptables rules is made available in a different format. Also,
iptables is not started correctly, it must be started immediately after the dhcp
lease information is acquired.

Expected Results:  1. The dhcpcd package should be included in RH8.
2. Uninstalling dhclient and installing dhcpcd should result in dhcpcd friendly
networking scripts that allow a working pre-RH8 dhcp configuration to be carried
forward.

Additional info:

Comment 1 Elliot Lee 2002-12-10 20:45:38 UTC
I can't find anything in our current iptables package that references dhcpcd-specific stuff., 
so I'm assuming this something outside the distribution.

Switching from dhcpcd to dhclient is intentional, and dhcpcd is unsupported in 8.0. 
Migrating custom scripts is admittedly not going to be painless, but such is progress... :\


Note You need to log in before you can comment on or make changes to this bug.