Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78093 - kernel build from src rpm doesn't build to correct platform
Summary: kernel build from src rpm doesn't build to correct platform
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm-build
Version: 7.2
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-18 23:40 UTC by Joseph Shraibman
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-22 17:33:52 UTC


Attachments (Terms of Use)

Description Joseph Shraibman 2002-11-18 23:40:06 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020826

Description of problem:
Doing rpm --rebuild kernel-2.4.18-18.7.x.src.rpm on i686 and athlon machines
builds kenel packages for i386, not i686 or athlon. The build process should
automatically detect the correct architecture.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1.rpm --rebuild kernel-2.4.18-18.7.x.src.rpm


Additional info:

What exactly is the format for the --target option? The man page for rpm says
arch-vendor-os but what do I use for vendor and os?

Comment 1 Arjan van de Ven 2002-11-19 08:55:10 UTC
rpmbuild --rebuild --target i686 kernel-2.4.18-18.7.x.src.rpm


Comment 2 Jeff Johnson 2002-11-22 14:58:46 UTC
vendor and os can be (and usually are)
skipped for linux.

Comment 3 Joseph Shraibman 2002-11-22 17:33:45 UTC
1) Just because there is a workaround doesn't mean this isn't a bug
2) If vendor and os aren't required say so in the documentation. Users like me
have no way of knowing that vender and os aren't required.


Note You need to log in before you can comment on or make changes to this bug.