Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78092 - default TWM titlebar & iconmgr font not found after new RH8 install
Summary: default TWM titlebar & iconmgr font not found after new RH8 install
Keywords:
Status: CLOSED DUPLICATE of bug 66330
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86
Version: 8.0
Hardware: i586
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-18 23:35 UTC by Need Real Name
Modified: 2007-04-18 16:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-19 08:26:58 UTC


Attachments (Terms of Use)

Description Need Real Name 2002-11-18 23:35:14 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021108

Description of problem:
After a new RH8 install without Gnome and without KDE (TWM is used as window
manager) and text login selected during the install, the default TWM titlebar
font and the default iconmgr font are not found. No text is shown in titlebars
(which appear much larger than normal) nor in the iconmgr icons for iconified
windows. I have verified that the fonts.dir and fonts.alias files are valid and
that xfs is running.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Perform a fresh RH8 install without Gnome & without KDE with "text login"
selected during the install. Copy .xinitrc (along with other .x files) and
.twmrc from previously used RH73 installation to the RH8 root directory (for
login as root). Reboot RH8 and login as root.
	

Actual Results:  As in description.

Expected Results:  Prior to RH8 this problem didn't occur. TWM should find the
correct default fonts whether they're coming from the xfs font server or whether
the font path is explicitly set in .xinitrc for the X server operating without xfs.

Additional info:

Explicitly specifying a font in .twmrc for the titlebar, menus, and iconmgr
seems to work for some fonts. This behavior is a bug however because TWM
normally chooses an optimal default font based on current settings. This
behavior forces users to use trial-and-errors in an attempt to arrive at a
usable font. I have not been able to force TWM to use the default fonts that
were in use with RH73 and earlier.

Comment 1 Need Real Name 2002-11-19 08:26:51 UTC
This bug apparently is a repeat of #66330 which occured for RH73. Since RH8
provides a newer XFree86 package and the problem still exists perhaps this is
something worth looking into. Thanks.

Comment 2 Mike A. Harris 2002-11-20 16:13:03 UTC

*** This bug has been marked as a duplicate of 66330 ***


Note You need to log in before you can comment on or make changes to this bug.