Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78083 - child segfault on any request for directory with .htaccess
Summary: child segfault on any request for directory with .htaccess
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: httpd
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact: Brian Brock
URL: http://www.dracodigital.com/private/
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-18 21:08 UTC by Jay Hodges
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-01-25 16:47:37 UTC


Attachments (Terms of Use)

Description Jay Hodges 2002-11-18 21:08:59 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98; Win 9x 4.90; 
H010818; .NET CLR 1.0.3705)

Description of problem:
After setting up .htaccess files, configuring /etc/httpd/conf/httpd.conf and
restarting httpd, the child process segfaults and the browser standard page 
cannot be found error is displayed in browser.

/var/log/httpd/errors says:
[notice] child pid 20731 exit signal Segmentation fault (11)



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.create html document in a new directory, test that it gets delivered correctly
2.in /etc/httpd/conf/httpd.conf, set AllowOverride AuthConfig or All in 
<Directory /> and
<Directory "/home/*/public_html">
3.in the directory with the webpage, create a .htaccess file:

AuthType Basic
AuthName "HodgesFamily"
AuthUserfile /home/draco/public_html/private/.htaccess
require valid-user

4. run service httpd restart
5. try to open the page

	

Actual Results:  Error Log shows segfault in child process.  Browser (IE 6.0) 
shows standard page not found text.


Expected Results:  Auth box should have popped up.

Additional info:

modified des.h file in OpenSSL to install SSLeay
IBM XSeries 300 Server

httpd-2.0.40-8 i386
openssl-0.9.6b-29 i686

Comment 1 Joe Orton 2002-11-28 14:57:47 UTC
I can't reproduce this.  What does "modified des.h file in OpenSSL to install
SSLeay" mean?  You have recompiled the RPMs?

Comment 2 Jay Hodges 2002-11-29 15:10:17 UTC
During the complie of SSLeay from source, there is an error and one line in 
des.h needs to be commented out for SSLeay to install properly.  No RPM's were 
rebuilt.

/usr/include/openssl/des.h Line 193



Comment 3 Joe Orton 2005-01-25 16:47:37 UTC
Thanks for the report.  This is a mass bug update; since this release
of Red Hat Linux is no longer supported, please either:

a) try and reproduce the bug with a supported version of Red Hat
Enterprise Linux or Fedora Core, and re-open this bug as appropriate
after changing the Product field, or,

b) if relevant, try and reproduce this bug using the current version
of the upstream package, and report the bug upstream.

c) report the bug to the Fedora Legacy project who may wish to
continue maintenance of this package.



Note You need to log in before you can comment on or make changes to this bug.