Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78067 - cannot create new keyboard shortcuts
Summary: cannot create new keyboard shortcuts
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: metacity
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-18 17:16 UTC by chrism
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-18 17:16:41 UTC


Attachments (Terms of Use)

Description chrism 2002-11-18 17:16:34 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021017

Description of problem:
in previous window managers new keyboard shortcuts could be created for
arbitrary commands (ie opening a new xterm) this functionality seems to be
missing from metacity.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. in sawfish there was an 'add...' option under shortcuts

	

Additional info:

Comment 1 Havoc Pennington 2002-11-18 17:22:20 UTC
It's there, just not in the prefs dialog.

Poke around under /apps/metacity in gconf-editor, or use gconftool-2.

gconftool-2 --type string --set /apps/metacity/keybinding_commands/command_1 'xterm'

gconftool-2 --type string --set /apps/metacity/global_keybindings/run_command_1
'<Ctrl><Alt>x'

may land in the prefs dialog sometime, but that would be done on gnome.org level 
not here. (http://bugzilla.gnome.org/, I'm not sure if the bug is already filed)


Note You need to log in before you can comment on or make changes to this bug.