Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78056 - no dri with radeon mobility 7500 on IBM ThinkPad T30
Summary: no dri with radeon mobility 7500 on IBM ThinkPad T30
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-18 15:56 UTC by Chris Runge
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-12-15 10:29:59 UTC


Attachments (Terms of Use)
/etc/X11/XF86Config (deleted)
2002-11-18 15:57 UTC, Chris Runge
no flags Details
/sbin/lspci -v (deleted)
2002-11-18 15:59 UTC, Chris Runge
no flags Details
output of glxinfo (deleted)
2002-11-18 16:00 UTC, Chris Runge
no flags Details

Description Chris Runge 2002-11-18 15:56:56 UTC
Description of Problem:

I have an IBM Thinkpad T30 that has a Radeon Mobility 7500 w/ 16 MB of RAM.
While my desktop system with a Radeon 7500 supports DRI, I am unable to get DRI
enabled on the T30. I am unsure if this is a configuration problem or if the
Radeon Mobility 7500 is for some reason not supported w/DRI yet.

A look at /sbin/lsmod shows that neither the agpgart nor radeon modules are
loaded. However, loading these modules does not seem to help.

Version-Release number of selected component (if applicable):

Red Hat Linux 8.0 w/ XFree86-4.2.0-72

Comment 1 Chris Runge 2002-11-18 15:57:49 UTC
Created attachment 85447 [details]
/etc/X11/XF86Config

Comment 2 Chris Runge 2002-11-18 15:59:35 UTC
Created attachment 85448 [details]
/sbin/lspci -v

Comment 3 Chris Runge 2002-11-18 16:00:21 UTC
Created attachment 85449 [details]
output of glxinfo

Comment 4 Chris Runge 2002-11-18 17:31:29 UTC
I suppose I should have attached the actual log file -- I will do this when I
get access to the system again.

Comment 5 Chris Runge 2002-11-19 13:15:43 UTC
odd. I've been playing around and dri seems to work with 16 bit color but not 24
bit. I'm not sure if this is a bug, a known issue, or intended behavior.

Comment 6 Mike A. Harris 2002-12-15 10:29:59 UTC
Assuming problem was just a configuration glitch, since you have not
supplied the log file I requested.  If this is still a problem for you,
reopen the bug report and attach your /var/log/messages, and X server
log, as well as updated config file.


Note You need to log in before you can comment on or make changes to this bug.