Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78052 - Broadcast address misscalculation for alias interfaces
Summary: Broadcast address misscalculation for alias interfaces
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-18 15:31 UTC by Tarhon-Onu Victor
Modified: 2014-03-17 02:32 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-14 04:55:20 UTC


Attachments (Terms of Use)

Description Tarhon-Onu Victor 2002-11-18 15:31:10 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020823
Netscape/7.0

Description of problem:
If you do not specify BROADCAST= in config files for alias interfaces, the
broadcast address will be not recalculated if already specified in parent's
interface configuration file.
That's because ifup-aliases evaluates variable from parent interface's
configuration file (somewhere before the declaration of function ini_env()), and
if BROADCAST is already specified in $PARENTCONFIG, a variable default_BROADCAST
is set with parent interface's broadcast, and then ini_env() which is performed
for every alais interface initializes BROADCAST with default_BROADCAST, so [ -z
"$BROADCAST" ] from function new_interface() will return false for every alias
interface, causing BROADCAST not to be recalculated.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. comment/delete BROADCAST=something line from a primary interface
configuration file, if any (line like this);
2. edit a secondary interface and do not specify the broadcast address.
3. ifup-alias ethX && ip add sh dev ethX:Y.
	

Actual Results:  The broadcast address will be that of the primary interface.

Expected Results:  The broadcast address should be calculated for every
secondary interface.



Additional info:

Comment 1 Bill Nottingham 2003-01-14 04:55:20 UTC
Changed in 7.03-1.


Note You need to log in before you can comment on or make changes to this bug.