Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78048 - PHP seems to not include a mysql library
Summary: PHP seems to not include a mysql library
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: php
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-18 14:00 UTC by Bishop Clark
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-18 14:00:29 UTC


Attachments (Terms of Use)

Description Bishop Clark 2002-11-18 14:00:23 UTC
Description of Problem:
Although PHP on RHL 7.3 includes libraries for accessing pgsql servers, mysql
seems to not be supported.

Version-Release number of selected component (if applicable):
mysql-3.23.49-3

How Reproducible:
Oh, pretty much all the time.

Steps to Reproduce:
1. Put this on a php page:
2. <? $link = mysql_connect ("localhost", "root", ""); ?>
3. viewing the page will give the following error:

Actual Results:
Fatal error: Call to undefined function: mysql_connect() in
/home/bishop/public_html/work.php on line 

Expected Results:
Another error, possibly related to authentication on the local mysql db.

Additional Information:
I may be wrong on this.  I hope I am, because it means I don't have to reroll
the RPM for myself.  It's Muy Annoying to try and keep pace with the updates -
I'm working 36 hour shifts as it is!

Comment 1 Bishop Clark 2002-11-18 14:09:20 UTC
Yep, I'm a ninny.  It's so late/early I'm not reading the specfile correctly and
seeing the %package mysql.  Must sleeeep... must slee-ooh, caffeine!

Sorry folks.




Note You need to log in before you can comment on or make changes to this bug.