Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78046 - up2date prompts error when there is nothing to update
Summary: up2date prompts error when there is nothing to update
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date
Version: 8.0
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-18 12:59 UTC by Need Real Name
Modified: 2007-04-18 16:48 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-08-20 19:52:04 UTC


Attachments (Terms of Use)

Description Need Real Name 2002-11-18 12:59:22 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020823
Netscape/7.0

Description of problem:
If there isn't any packages available to download and I click the forward
button, I get an error message telling me that I have to select a package to
continue or click cancel to exit. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Type up2date
2. You should have all the latest updates installed before you continue
3. Click the forward button
4. Bingo!
	

Actual Results:  Prompted with an Error message

Expected Results:  I shouldn't be prompted with an error message when I have all
the latest updates. If there isn't any packages available to update, it should
automatically move me onto the next page and tell me that I have all the latest
updates at this time and have the ability to click finish. Instead, it gives me
an ugly error message telling me to click cancel. It isn't mission critical but
it would be a user friendly improvement.

Additional info:

Comment 1 Michael Lee Yohe 2002-11-18 20:19:10 UTC
What is the version of the up2date package that you have?  I have the following:

$ rpm -q up2date
up2date-3.0.7-1

When my machine is fully up2date, it simply pops up a dialog box that says
"You're up2date" (more or less) - click OK and then up2date disappears.  So... wfm.


Comment 2 Need Real Name 2002-11-18 23:11:04 UTC
I have up2date version 3.0.7-1

My Error messages says:

You must select at least one package.
If you dont wish to update any packages,
press the "Cancel" button to exit Update Agent.

I don't get anything that says I am up2date, just a blank page with no packages
to install. What I'm talking about is the "packages to be updated" page, not the
packages to be skipped page. I skip the kernel package and kernel-source package
because I am fine with the current kernel. Even if I skip the kernel packages I
still shouldn't get that type of error message because I skipped the packages on
the "Packages Flagged to be Skipped" page. If I need to have the kernel packages
updated as well to get the popup message that say I am up2date that is fine but
the error message is still incorrect because I flagged them to be skipped. It
should say "There is no packages to be updated at this time" or something of
those lines.

Comment 3 Need Real Name 2002-11-18 23:17:42 UTC
One more thing, it should say Alert! not Error! It isn't really an error to be
called an error. Well, that is my opinion anyways. Cheers!


Note You need to log in before you can comment on or make changes to this bug.