Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78045 - libgnomecanvas binary rpm doesn't build
Summary: libgnomecanvas binary rpm doesn't build
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: libgnomecanvas
Version: 8.0
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact: Jay Turner
URL:
Whiteboard:
Depends On:
Blocks: 79579
TreeView+ depends on / blocked
 
Reported: 2002-11-18 12:35 UTC by Bernd Kischnick
Modified: 2015-01-08 00:01 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-16 13:59:32 UTC


Attachments (Terms of Use)
patch to the spec file (deleted)
2002-11-18 12:36 UTC, Bernd Kischnick
no flags Details | Diff

Description Bernd Kischnick 2002-11-18 12:35:48 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:0.9.8) Gecko/20020310

Description of problem:
Building a binary RPM from the source RPM fails, unless an old version of the
binary RPM is already installed on the build host.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
rpm -e libgnomecanvas libgnomecanvas-devel
rpm -ivh libgnomecanvas-2.0.2-1.src.rpm
rpmbuild -bb SPECS/libgnomecanvas.spec
	

Actual Results:  rpmbuild fails in %install:
libtool doesn't find libcanvas-2.so to re-link libglade/2.0/libcanvas.so

Expected Results:  binary RPM should be built.

Additional info:

libtool wants to perform a re-link step to install libglade/2.0/libcanvas.so to
the build root. libtool assumes that libcanvas-2.so has already been installed
to its final destination, /usr/lib, but it's in the build root instead.

This can be fixed by pointing the environment var LIBRARY_PATH into the build
root while %installing.

Comment 1 Bernd Kischnick 2002-11-18 12:36:42 UTC
Created attachment 85404 [details]
patch to the spec file

Comment 2 Havoc Pennington 2002-12-14 02:19:17 UTC
Hmm, I thought we'd fixed libtool not to do this.

Comment 3 Jens Petersen 2002-12-16 07:46:41 UTC
We have, but it looks like the "ltmain.sh" in libgnomecanvas
wasn't generated with it...

(The relink patch is not upstream yet.)

Comment 4 Havoc Pennington 2003-01-02 23:19:45 UTC
Just need to run libtoolize in libgnomecanvas spec file I guess.

Comment 5 Alexander Larsson 2003-01-16 13:59:32 UTC
Fixed in libgnomecanvas-2.1.90-2. (I just added libtoolize -f to %build)



Note You need to log in before you can comment on or make changes to this bug.