Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78037 - Executable completion fails if executable is in a subdirectory
Summary: Executable completion fails if executable is in a subdirectory
Keywords:
Status: CLOSED DUPLICATE of bug 72512
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: bash
Version: 8.0
Hardware: i686
OS: Linux
medium
low
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-18 05:45 UTC by William Shubert
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-18 14:05:02 UTC


Attachments (Terms of Use)

Description William Shubert 2002-11-18 05:45:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
In bash 1, if I have a subdirectory "veryLongDir" containing the executable
"longerExecutable", I can run it by typing "./ver<tab>", at which point
"./veryLongDir/" appears, then I can type "lon<tab>" and the full
"./veryLongDir/veryLongExecutable " appears, ready for me to type arguments. Great!

In Bash 2.05b, it inserts a space instead of the "/" after the "veryLongDir/",
so I type "./ver<tab>", get "./veryLongDir ", and then I must go and manually
backspace, press "/", then type again to get the next level. When I have a
binary several subdirectories deep, this is incredibly annoying. Since having a
directory name as the first part of a shell command is useless, it seems this is
strictly wrong behavior, it should always insert the "/" instead of the space.

Version-Release number of selected component (if applicable): 2.05b


How reproducible:
Always

Steps to Reproduce:
1. mkdir veryLongDir
2. echo ls >veryLongDir/longerBinary
3. chmod +x veryLongDir/longerExecutable
4. ./ver<tab>


Actual Results:  Command prompt shows useless "./veryLongDir "

Expected Results:  It should show "./veryLongDir/"

Additional info:

Note that if you tab-complete as an argument, it does the right thing; "cat
./ver<tab>" will turn command prompt into "cat ./veryLongDir/". So it is only
wrong when you are typing the executable name.

Comment 1 Tim Waugh 2002-11-19 09:46:29 UTC

*** This bug has been marked as a duplicate of 72512 ***


Note You need to log in before you can comment on or make changes to this bug.