Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78017 - Canna server doesn't operate well on Gnome Desktop.
Summary: Canna server doesn't operate well on Gnome Desktop.
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kinput2
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Akira TAGOH
QA Contact: Bill Huang
URL:
Whiteboard:
: 85832 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-17 16:41 UTC by Need Real Name
Modified: 2007-04-18 16:48 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-04-22 13:25:14 UTC


Attachments (Terms of Use)

Description Need Real Name 2002-11-17 16:41:48 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ja-JP; rv:1.0.1) Gecko/20020823
Netscape/7.0

Description of problem:
With every applications used on Gnome Desktop, Canna server doesn't operate
well. After input of Japanese !Hkana!I language, when I push the space bar 2 times
or more to chose another candidate of Japanese !Hkanji!I language, operation of
Canna server is stopped.
On KDE Desktop these trouble doesn't happen, and Canna server operates well.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. push the shift key and space bar together to start Canna on a application on
Gnome Desktop
2. input of Japanese !Hkana!I language
3. push the space bar 2 times or more (or use a arrow key in the !Hichiran!I
window) to chose another candidate of Japanese !Hkanji!I language
4. push the enter key to decide the candidate of Japanese !Hkanji!I language


Actual Results:  Canna server stops it's operation, and Japanese !Hkanji!I
language isn't displayed correctly.

Expected Results:  Canna server continues it's operation well, and Japanese
!Hkanji!I language is displayed correctly


Additional info:

On KDE Desktop these trouble doesn't happen, and Canna server operates well. So,
I think these trouble becomes from a bug of Gnome Desktop.

Comment 1 Need Real Name 2002-11-17 16:49:10 UTC
!H and !I in the description above are bad letters. Thease are " correctly.

Comment 2 Owen Taylor 2003-01-06 20:57:03 UTC
I think this is a Canna or kinput2 bug that gtk2 just happens to trigger.
(I haven't tried to reproduce it, going from the above description.)

Comment 3 Akira TAGOH 2003-04-21 08:51:54 UTC
I'm reassigning it to kinput2 now. but I don't know it's kinput2 bug or Canna
bug. at least kinput2 has a way to avoid this.

Comment 4 Akira TAGOH 2003-04-21 08:53:02 UTC
*** Bug 85832 has been marked as a duplicate of this bug. ***

Comment 5 Akira TAGOH 2003-04-22 13:25:14 UTC
fixed in v3.1-8


Note You need to log in before you can comment on or make changes to this bug.