Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78004 - NFS: lockd can't monitor client / client can't lock files
Summary: NFS: lockd can't monitor client / client can't lock files
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: nfs-utils
Version: 7.3
Hardware: i586
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Stephen Tweedie
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-17 09:09 UTC by Felix Tiede
Modified: 2007-04-18 16:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-03-10 16:48:46 UTC


Attachments (Terms of Use)

Description Felix Tiede 2002-11-17 09:09:07 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
If a nfs-client tries to lock a file on the nfs-server, the server reports
"lockd: cannot monitor <client-ip>" directly to the console without producing
any logentries.

Some applications on the client (like gnome-volume-control) report the unability
to lock files and continue, others (esp. gnome2) report it and abort.

This bug occurs since i've updated the client from RedHat Linux 7.3 (which
worked well) to RedHat Linux 8.0.

Version-Release number of selected component (if applicable):
1.0.1-2

How reproducible:
Always

Steps to Reproduce:
1. mount /home from nfs-server (server: RedHat Linux 7.3, client: RedHat Linux 8.0)
2. start gnome2 (as none-root)


Actual Results:  Errormessage: "Can't lock %gconf-xml-backend.lock. Aborting"

Expected Results:  Nothing, just a started gnome2

Additional info:

Both systems (server and client) are kept up-to-date with all errata installed.
Kernel on server: 2.4.18-17.7.x
Kernel on client: 2.4.18-17.8.0

nfs-utils on both systems: 1.0.1-2

Comment 1 Stephen Tweedie 2002-11-18 17:18:39 UTC
Are there any log messages produced on the client?  Check your firewall setup on
the client to make sure that the server's statd requests are not being blocked.

Comment 2 Felix Tiede 2002-11-18 22:10:01 UTC
First message is from gnome2 (while starting gnome2) that
~/.gnome-locking-test-file (or so) could not be locked. It says I should check
my nfslock service, which is running.

/var/log/messages states that a session was opened and closed.

There is no firewall on the client and the firewall on the server is configured
to pass any packets on the interface in question.

Comment 3 Stephen Tweedie 2004-03-10 16:48:46 UTC
Please reopen if the problem persists with a current release.


Note You need to log in before you can comment on or make changes to this bug.