Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 78000 - When a password with the B# sign is used it does not recognise it.
Summary: When a password with the B# sign is used it does not recognise it.
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: passwd
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-17 03:58 UTC by P H
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-03-24 19:57:23 UTC


Attachments (Terms of Use)

Description P H 2002-11-17 03:58:30 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
When a password with the B# sign is used it does not recognise it.
When i try to login the swat with the root password having a B# sign in it, it 
does not recognise the password.
Same if ftping or telneting to the linux box or out to another box.
Its like it is send a different symbol instead of the B# sign.
If i type a B# sign in the the terminal window I see a B# sign, it seems to be 
only in the password where the problem is
I have the Keyboard set to a UK keyboard.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Use The B# sign in a password
2.
3.
	

Actual Results:  access denied

Expected Results:  access granted

Additional info:

Comment 1 Mark J. Cox 2003-04-23 10:59:26 UTC
Can you explain which key you are pressing to give you a "B#" sign?  I suspect 
that bugzilla is converting the sign so it isn't appearing correctly in this 
bug report.  

test: UK keyboard shift+3 (pound)='£', euro='â¬', shift top left key ='¬' 

Comment 2 Mark J. Cox 2003-04-23 11:44:09 UTC
User reports in private email that this is in fact the UK pound sign 
(shift+3).  I can't duplicate this issue on 7.2 or 9

Comment 3 Tomas Mraz 2005-03-24 19:57:23 UTC
This works fine for me on the current Fedora Core. I think this was most
probably some mismatch of character encoding used by passwd and other services
in RHL-8.



Note You need to log in before you can comment on or make changes to this bug.