Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77999 - When a password with the # sign is used it does not recognise it.
Summary: When a password with the # sign is used it does not recognise it.
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: samba
Version: 8.0
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-17 03:56 UTC by P H
Modified: 2007-04-18 16:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-23 18:18:54 UTC


Attachments (Terms of Use)

Description P H 2002-11-17 03:56:48 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
When a password with the # sign is used it does not recognise it.
When i try to login the swat with the root password having a # sign in it, it 
does not recognise the password.
Same if ftping or telneting to the linux box or out to another box.
Its like it is send a different symbol instead of the # sign.
If i type a # sign in the the terminal window I see a # sign, it seems to be 
only in the password where the problem is
I have the Keyboard set to a UK keyboard.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Use The # sign in a password to access swat or telnet or ftp
2.
3.
	

Actual Results:  access denied

Expected Results:  access granted

Additional info:

Comment 1 Andrew Bartlett 2002-12-29 00:29:42 UTC
might be due to URL encoding - I'll have a look at it

Comment 2 Andrew Bartlett 2003-01-26 23:56:38 UTC
Actually, this is sounding like a generic 'code page' issue.  Should we convert
passwords between code pages prior to checking them - which is fine for SWAT, but 
only in 3.0.  However, things like FTP are a bit different.  (and not relevent
here).  

Andrew Bartlett

Comment 3 Andrew Bartlett 2003-02-01 06:22:52 UTC
I've commited a change to Samba HEAD that should convert your username/password
into our 'unix' charset.   I have no idea if it would actually help, as it
depends very much on what charset the password was hashed in, but it seems a
better idea than just assuming it doesn't matter.


Note You need to log in before you can comment on or make changes to this bug.