Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77988 - rpm-4.1-9 lockup problem found, fix within?
Summary: rpm-4.1-9 lockup problem found, fix within?
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm
Version: 8.0
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-16 21:34 UTC by Warren Togami
Modified: 2005-10-31 22:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-16 21:34:15 UTC


Attachments (Terms of Use)

Description Warren Togami 2002-11-16 21:34:08 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
rpm-4.1-1.06 was initially broken with some race condition that would cause
lockups very often (with and without apt-get.)  Since then rpm-4.1-9 was
released as test packages.  The reports of rpm-4.1-9 locking up may have been
this bug in rpm that Conectiva fixed a few months ago.  Those people who were
using apt-get but aborted left behind __db* files which blocked rpm from working
properly.  Please check out these links:

http://lists.freshrpms.net/pipermail/rpm-list/2002-November/002126.html
http://bugzilla.conectiva.com/show_bug.cgi?id=4823
http://bugzilla.conectiva.com/show_bug.cgi?id=4688

The fix mentioned in the above links have subsequently been tested on Red Hat
and SuSE, although I'm not exactly sure why it works since rpm itself (without
apt-get) leaves behind __db* files after normal use.  Could someone please
explain how this works?

Most of Conectiva's Bugzilla is in Portuguese so I cannot read their solution to
this problem.

Version-Release number of selected component (if applicable):
Red Hat 8.0

How reproducible:
Always

Steps to Reproduce:
1. Use 3rd party apt-get.
2. CTRL-C abort before it finishes.

Actual Results:  
rpm fails.

Expected Results:  
rpm should be able to handle this situation.

Comment 1 Jeff Johnson 2002-11-16 22:05:33 UTC
The important part of the configuration change
is "private", the rest just (more or less) duplicates
what is compiled/configured by default in rpm.

The effect of "private" is to use an internal, malloc'd
environment, essentially eliminating the possibility
of concurrent access with record locks, running the
(minor but real IMHO) risk of 2 rpmdb writers clobbering
everything.

Hmmm, so all these hangs are coming from apt users. You
might get someone with a clue about Conectiva apt to talk
to me so that a real solution can be figgered.

AFAIAC the "real" solution is to use NPTL on /dev/futex,
almost there.

Comment 2 Milan Kerslager 2003-01-10 22:49:26 UTC
I see many lockups on RH 8.0 system, minimal install, in the class with my
students when trying to heavily install various packages.

Hope NTPL will give it away.

Comment 3 dkaplan 2003-04-17 00:36:17 UTC
This bug continues on Redhat 9.0 with the newest version of apt from freshrpms.
 I have since added the lines to /etc/rpm/macros.  Too early to tell if that helps.

I thought 9.0 was supposed to have the famous NTPL?




Note You need to log in before you can comment on or make changes to this bug.