Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 7798 - emacs-X11 - unpacking of archive failed: cpio: Bad magic
Summary: emacs-X11 - unpacking of archive failed: cpio: Bad magic
Keywords:
Status: CLOSED DUPLICATE of bug 7830
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: emacs
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
: 7782 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-12-13 21:33 UTC by Jaroslaw Sosnicki
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-12-17 19:06:12 UTC


Attachments (Terms of Use)

Description Jaroslaw Sosnicki 1999-12-13 21:33:00 UTC
rawhide-release-19991213-1.noarch.rpm

when installing emacs-X11 the folowing message is generated
emacs-X11    ##################################################
unpacking of archive failed: cpio: Bad magic

Comment 1 Jeff Johnson 1999-12-14 17:42:59 UTC
This message is usually caused by a damaged rpm.

What does
	rpm2cpio emacs-X11 | cpio -itv
have to say? If "premature end of file", then the package is somehow
damaged.

Comment 2 Jaroslaw Sosnicki 1999-12-15 02:02:59 UTC
pm2cpio emacs-X11-20.4-5.i386.rpm | cpio -itv
-rw-r--r--   1 root     root          196 Dec  8 05:02
etc/X11/applnk/Applications/emacs.desktop
-rw-r--r--   1 root     root           95 Dec  8 05:02 etc/X11/wmconfig/emacs
-rwxr-xr-t   2 root     root            0 Dec  8 05:02 usr/bin/emacs
-rwxr-xr-t   2 root     root      2903024 Dec  8 05:02 usr/bin/emacs-20.4
cpio: premature end of file

Comment 3 dunwoody 1999-12-17 08:02:59 UTC
*** Bug 7782 has been marked as a duplicate of this bug. ***

Comment 4 dunwoody 1999-12-17 08:08:59 UTC
I get the same results as slavko@home.com from the rpm2cpio pkg.rpm |cpio -itv
test.

Since emacs-X11-20.4.5.i386.rpm was made available, two new, unrelated rpms
have appeared on rawhide with the same problem:

isapnptools-1.21-1.i386.rpm
lesstif-2.0-devel-0.89.4-1.i386.rpm

So it would appear this is not an emacs problem, but more likely an rpm
packaging problem.

Comment 5 dunwoody 1999-12-17 08:14:59 UTC
This bug is a duplicate of 7830 and should be closed (I can't do that myself).

Comment 6 Bill Nottingham 1999-12-17 19:06:59 UTC
*** This bug has been marked as a duplicate of 7830 ***


Note You need to log in before you can comment on or make changes to this bug.