Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77967 - $RPM_INSTALL_PREFIX not set for rpm scripts
Summary: $RPM_INSTALL_PREFIX not set for rpm scripts
Keywords:
Status: CLOSED DUPLICATE of bug 75550
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm
Version: 8.0
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-15 22:58 UTC by Mark Vanderwiel
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-15 22:58:31 UTC


Attachments (Terms of Use)

Description Mark Vanderwiel 2002-11-15 22:58:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 4.0; Q312461)

Description of problem:
I see a problem where $RPM_INSTALL_PREFIX is not being set during %post and %
postun script processing.
rpm version 4.1-1.06


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run rpm with any rpm that uses $RPM_INSTALL_PREFIX in its scripts 
2.
3.
	

Actual Results:  $RPM_INSTALL_PREFIX is NOT set during rpm scripts, crashes our 
rpm install scripts

Expected Results:  $RPM_INSTALL_PREFIX should be set during rpm scripts and our 
install script run successfully.

Additional info:

This is starting to affect customers trying to install our product rpms on 
RedHat 8.0.

Comment 1 Jeff Johnson 2002-11-16 20:08:31 UTC

*** This bug has been marked as a duplicate of 75550 ***


Note You need to log in before you can comment on or make changes to this bug.