Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77949 - Too many requires in spec file
Summary: Too many requires in spec file
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glut
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-15 19:03 UTC by Alex Yacoub
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-15 19:08:52 UTC


Attachments (Terms of Use)

Description Alex Yacoub 2002-11-15 19:03:32 UTC
Description of Problem:


Version-Release number of selected component (if applicable):


How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:

Comment 1 Alex Yacoub 2002-11-15 19:08:46 UTC
Sorry about that.  Here's the real bug:

In the spec file to glut, there is a line
Requires:      /usr/lib/libGL.so.1

The problem is that the FindRequires script of rpmbuild automatically discovers
what the requires are, and this line is unneeded.  libGL.so.1 is a symlink, and
many packages provide the library, but not that actual file (which ldconfig
creates).

Having this line in the spec file prevents uninstalling the XFree86-Mesa-libGL
package and installing another package that provides the library, such as
NVIDIA's package.

The solution is to remove that line from the spec file.  It does not cause any
problems as running rpm -q --requires glut shows libGL.so.1 as one of the lines,
instead of /usr/lib/libGL.so.1.

I hope that made sense....

Comment 2 Mike A. Harris 2002-11-18 18:26:33 UTC
Fixed in 3.7-9 in rawhide (I think)


Note You need to log in before you can comment on or make changes to this bug.