Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77933 - Samba network printing with Lexmark z51 corrupts the image
Summary: Samba network printing with Lexmark z51 corrupts the image
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: samba
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jay Fenlason
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-15 16:08 UTC by Panic
Modified: 2014-08-31 23:24 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-17 19:33:48 UTC


Attachments (Terms of Use)
a sample of the distortion (deleted)
2002-11-15 16:17 UTC, Panic
no flags Details

Description Panic 2002-11-15 16:08:26 UTC
Description of Problem:

Installed Lexmark z51 using lx5000 driver on a RHL7.3 print server running
LPRng.  Local printing is fine, test page works, all is well.

Attempts to print remotely fail in two different ways.  One is only on Windows
clients:  The (NT4) print manager gives an Access Denied error, and will not
print.  I believe this may be due to Samba miscofiguration, so I'll leave it
alone for now. 

The second failure is a corruption of the printed document (in this case the Red
Hat test page).  The job does actually print, but the document is distorted. 
This occurs for both Linux and Windows clients.

We've attempted to use a raw print queue; the jobs either didn't print at all or
came out the same (distorted).  Switching to CUPS did not seem to have any
effect one way or the other.

Attempts to print things remotely from programs besides printconf-gui either do
not work (access denied on Windows) or show up with similar distortion.

I'm filing this under Samba because local printing works fine -- only network
printing is affected.

I'm filing this bug on behalf of Amelia County Schools.  Their contact is
blynch@ameliaschools.com; he can answer any specific questions as he is on site
there.


Version-Release number of selected component (if applicable):

2.2.3a-6

How Reproducible:

Always (except for when we get the access denied error)

Steps to Reproduce:
1. Install Lexmark Z51, share to network via samba
2. Install printer as a remote printer on Windows or RHL7.3 client
3. Attempt to print from another RHL7.3 client or a Windows machine
 

Actual Results:

printed document is distorted

Expected Results:

printed document should be the same as when printed locally.

Additional Information:

Comment 1 Panic 2002-11-15 16:17:02 UTC
Created attachment 85205 [details]
a sample of the distortion


Note You need to log in before you can comment on or make changes to this bug.