Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77928 - jed package missing xjed
Summary: jed package missing xjed
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: jed
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Jay Turner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-15 14:50 UTC by nvwarr
Modified: 2015-01-08 00:01 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-15 14:50:21 UTC


Attachments (Terms of Use)

Description nvwarr 2002-11-15 14:50:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
The jed package now obsoletes the jed-xjed one, but does not provide the xjed
executable, although all the necessary code is in the .src.rpm.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Start with jed-0.99.14-2.i386.rpm, jed-common-0.99.14-2.i386.rpm, and
jed-xjed-0.99.14-2.i386.rpm installed
2.Upgrade to jed-0.99.15-3.i386.rpm

	

Actual Results:  jed-common and jed-xjed are obsoleted, and the xjed executable
is deleted, but is not replaced by a new version.

Expected Results:  The upgrade obsoletes jed-common and jed-xjed and should,
therefore, provide the xjed executable itself.

Additional info:

It can be fixed by changing the line:
all: jed rgrep
in the Makefile to:
all: jed rgrep xjed

and adding an install line to the .spec file.

Comment 1 Bill Nottingham 2002-11-15 19:39:01 UTC
The obsoletes is to fix bug 69832; xjed is no longer shipped as it wasn't really
something we wanted to support going forwards (we have other GUI editors.)

Comment 2 Sergio 2002-12-02 12:24:31 UTC
<flame>
Pray, I use Linux since just 6 year, and I may have missed something.
Which of the "other GUI editors" that "you have":
- has Emacs key bindings,
- has syntax highlight,
- starts in nearly zero time even on a K6/200,
- is usable trough a slow ssh/X11 tunnel,
- does not need a bunch of Gnome/KDE/OtherBloat libraries
- has a reasonable memory(2M) and disk(~210K) footprint
- does not suffer from funny 'DEL' mappings like jed in an xterm
 ???
 Am I missing something ? Am I supposed to run RH8 only on a 2GHz PentumIV ? 

Sorry, but I consider this a REAL bug - one more step towards making RH unusable
for me, and other people like me, who value speed and remote access more than
cute icons.

BTW, for those who still depend on it, the patch is so simple - just put back a
-with-x in the %configure, and a make xjed in the %build, few more lines in install.
I'll post the .spec next time I start up RH8 - in a few months, maybe.
</flame>



Comment 3 acount closed by user 2003-05-22 23:21:14 UTC
xjed is a code editor and not for to write letters or documents.


Note You need to log in before you can comment on or make changes to this bug.