Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77924 - KDE Crash dump while trying to button from Kpanel
Summary: KDE Crash dump while trying to button from Kpanel
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdelibs
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-15 14:18 UTC by Nathan Williams
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-15 14:19:00 UTC


Attachments (Terms of Use)

Description Nathan Williams 2002-11-15 14:18:50 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
I upgraded Evolution to version 1.2 off of Ximian's web site.  Kpanel now has a
"blank" icon where the mail icon use to be.  Blank Icon occupies space and
cannot be removed.  If I try to right click the pannel,remove,button KDE panel
will crash with a bugdump.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Note you must use Red Carpet to upgrade Evolution to version 1.2
2.Right click anywhere on pannel.
3.Click on Pannel,Remove, Button.
	

Actual Results:  Crash dump as follows:
(no debugging symbols found)...[New Thread 8192 (LWP 1870)]
0x420ae169 in wait4 () from /lib/i686/libc.so.6
#0  0x420ae169 in wait4 () from /lib/i686/libc.so.6
#1  0x4212a2d0 in __DTOR_END__ () from /lib/i686/libc.so.6
#2  0x40e16c63 in waitpid () from /lib/i686/libpthread.so.0
#3  0x406271a5 in KCrash::defaultCrashHandler(int) ()
   from /usr/lib/libkdecore.so.4
#4  <signal handler called>
#5  0x40b5b8f9 in QString::QString(QString const&) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#6  0x4173da27 in PanelRemoveButtonMenu::slotAboutToShow() ()
   from /usr/lib/kicker.so
#7  0x4173cf60 in PanelRemoveButtonMenu::qt_invoke(int, QUObject*) ()
   from /usr/lib/kicker.so
#8  0x408e9d6b in QObject::activate_signal(QConnectionList*, QUObject*) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#9  0x408e9c57 in QObject::activate_signal(int) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#10 0x40bc44ce in QPopupMenu::aboutToShow() ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#11 0x409d6eab in QPopupMenu::subMenuTimer() ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#12 0x40bc45f4 in QPopupMenu::qt_invoke(int, QUObject*) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#13 0x41737dad in RemoveContainerMenu::qt_invoke(int, QUObject*) ()
   from /usr/lib/kicker.so
#14 0x408e9d6b in QObject::activate_signal(QConnectionList*, QUObject*) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#15 0x408e9c57 in QObject::activate_signal(int) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#16 0x40bb2b4b in QTimer::timeout() ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#17 0x4090a792 in QTimer::event(QEvent*) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#18 0x40895c49 in QApplication::internalNotify(QObject*, QEvent*) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#19 0x408954f1 in QApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#20 0x405bb9a6 in KApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/libkdecore.so.4
#21 0x40838a88 in qt_activate_timers() ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#22 0x40836330 in QApplication::processNextEvent(bool) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#23 0x40897280 in QApplication::enter_loop() ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#24 0x409d79b6 in QPopupMenu::exec(QPoint const&, int) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#25 0x416f5f33 in ButtonContainer::eventFilter(QObject*, QEvent*) ()
   from /usr/lib/kicker.so
#26 0x408e7e5e in QObject::activate_filters(QEvent*) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#27 0x408e7d81 in QObject::event(QEvent*) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#28 0x4091e2ec in QWidget::event(QEvent*) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#29 0x40895c49 in QApplication::internalNotify(QObject*, QEvent*) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#30 0x40895363 in QApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#31 0x405bb9a6 in KApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/libkdecore.so.4
#32 0x40839b46 in QETWidget::translateMouseEvent(_XEvent const*) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#33 0x408369b6 in QApplication::x11ProcessEvent(_XEvent*) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#34 0x4083652f in QApplication::processNextEvent(bool) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#35 0x40897280 in QApplication::enter_loop() ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#36 0x4083602d in QApplication::exec() ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#37 0x416e2a97 in main () from /usr/lib/kicker.so
#38 0x0804cb9f in strcpy ()
#39 0x0804d8bb in strcpy ()
#40 0x0804dd7c in strcpy ()
#41 0x0804eb40 in strcpy ()
#42 0x420158d4 in __libc_start_main () from /lib/i686/libc.so.6


Expected Results:  List of buttons to remove should have appeared (duh...) ;-)

Additional info:

I guess I have a damaged config file for panel.  Have no idea where it is stored.

Note again this was caused by my upgrading Evolution to version 1.2

Comment 1 Ngo Than 2002-12-08 19:07:53 UTC
i have seen some similar problems in Bugzilla, which are fixed in the rawhide.

Anyway i cannot reproduce it on my local machine.


Note You need to log in before you can comment on or make changes to this bug.