Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77914 - On load: No available connection provider, plugins probably missing
Summary: On load: No available connection provider, plugins probably missing
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tora
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mihai Ibanescu
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-15 09:01 UTC by Need Real Name
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-12-03 13:11:13 UTC


Attachments (Terms of Use)

Description Need Real Name 2002-11-15 09:01:01 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
I downloaded the static compilation from globecom.se/tora/ (links to
http://prdownloads.sourceforge.net/tora/tora-1.2.4-1oracle9.i686.rpm)

Works fine with connection providers for Oracle and MySQL already installed. RH
8 notified me that an update exists for Tora, so I updated (using up2date).
After doing this, I get a dialog each time I start TOra: "No available
connection provider, plugins probably missing". I cannot connect to any databases.

I do have Oracle installed on the machine. And kdelibs.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Remove existing tora installation
2. Install http://prdownloads.sourceforge.net/tora/tora-1.2.4-1oracle9.i686.rpm
3. Launch up2date
	

Actual Results:  Tora configuration seems broken



Additional info:

Comment 1 Michael Lee Yohe 2002-11-15 17:03:06 UTC
up2date can only be trusted if you are using packages built from Red Hat source
RPMs.  That way, the files are put in the proper place and can be updated
properly.  This bug may need to go to up2date, since up2date should check to see
if the Packager of the currently installed package is indeed a Red Hat package.
 If it isn't, the user can opt to force an upgrade or to ignore the upgrade
altogether.

Comment 2 Need Real Name 2002-11-15 17:50:43 UTC
No an up2date issue. I get the exact same problem if I install the official
RPM from scratch.

Comment 3 Mihai Ibanescu 2002-11-17 18:32:09 UTC
Please note that 1.2.4 < 1.2.6.1, this is the reason why up2date offered to
upgrade the package. If you want up2date to ignore the newer (but not
Oracle-enabled) tora, you may add tora to up2date's skiplist.

I am not exactly sure I understand the bug report. Was tora-1.3.6.1 working
before, you installed 1.2.4, then you re-installed 1.3.6.1 and it doesn't work
anymore?

Comment 4 Need Real Name 2002-11-18 08:40:04 UTC
1.3.6.1 never worked for me and always gives the same error message
(see summary). The outcome is the same, regardless if I upgrade from 1.2.4
or install on a 'clean' machine.

1.2.4 from globecom works nicely.



Comment 5 Mihai Ibanescu 2002-11-18 15:25:24 UTC
Okay, I'll try to schedule some time to work on the tora package this week.tora
works like a charm on my machine (but it's a custom build for 7.3).

Comment 6 Mihai Ibanescu 2002-11-25 23:23:24 UTC
Here's the fix:

Install qt-ODBC and/or qt-PostgreSQL qt-MySQL; make sure you remove .tora* in
your home directory (they seem to be versioned, or at least that's what I think).
Then you'll start seeing the mysql and postgresql connection providers.

I would be really grateful if you downloaded the newer tora 1.3.8 rpms from:

ftp://people.redhat.com/misa/fixes/tora

and run those instead, since I'm trying to test the packaging on this one. I've
updated the package's description too.

Comment 7 Need Real Name 2002-11-28 10:57:31 UTC
It installed nicely, but failed to execute:

[oracle@dellbert oracle]$ tora
tora: relocation error: tora: undefined symbol: static_QUType_varptr



Comment 8 Mihai Ibanescu 2002-12-02 22:53:02 UTC
Yupp, my bad. Can you please try it now? Please make sure you rpm -e tora before
attempting to install the 3.8.0 packages. Thanks a lot.

Comment 9 Need Real Name 2002-12-03 08:13:59 UTC
I installed ftp://people.redhat.com/misa/fixes/tora/tora-1.3.8-3.8.0.i386.rpm
but I still get the same (original) error: "No available connection provider,
plugins probably missing"



Comment 10 Mihai Ibanescu 2002-12-03 13:02:51 UTC
Have you run:

rm -rf ~/.tora*

and installed qt-ODBC, qt-PostgreSQL and qt-MySQL?

Comment 11 Need Real Name 2002-12-03 13:11:05 UTC
I forgot to remove .tora* (duh!). Works fine now.


Comment 12 Mihai Ibanescu 2002-12-03 13:13:34 UTC
Yeah, not sure why those files are versioned and have to be changed - makes
upgrades a PITA.

If that's okay with you, I'm going to close this bug as RAWHIDE - there is a fix
available out there.


Note You need to log in before you can comment on or make changes to this bug.