Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77909 - i can't chnage the networksystemname
Summary: i can't chnage the networksystemname
Keywords:
Status: CLOSED DUPLICATE of bug 59017
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: redhat-config-network
Version: 2.1
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-15 08:14 UTC by Need Real Name
Modified: 2007-11-30 22:06 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:09 UTC


Attachments (Terms of Use)

Description Need Real Name 2002-11-15 08:14:43 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
Traceback (innermost last):
  File "/usr/sbin/neat", line 1210, in ?
    gtk.mainloop()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2608, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/sbin/neat", line 392, in on_applyButton_clicked
    self.save()
  File "/usr/sbin/neat", line 271, in save
    self.saveHardware()
  File "/usr/sbin/neat", line 283, in saveHardware
    hardwarelist.save()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NCHardwareList.py", 
line 276, in save
    modules.write()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/Conf.py", line 981, 
in write
    self[key] = self.vars[key]
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/Conf.py", line 933, 
in __setitem__
    findexp = '[\t ]*' + key + '[\t ]+' + varname + '[\t ]+'
TypeError: illegal argument type for built-in operation

Local variables in innermost frame:
missing: 1
key: options
place: 0
value: {'options': {}}
self: <netconfpkg.NCHardwareList.MyConfModules instance at 84debf0>
varname: None


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Traceback (innermost last):
  File "/usr/sbin/neat", line 1210, in ?
    gtk.mainloop()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2608, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/sbin/neat", line 392, in on_applyButton_clicked
    self.save()
  File "/usr/sbin/neat", line 271, in save
    self.saveHardware()
  File "/usr/sbin/neat", line 283, in saveHardware
    hardwarelist.save()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NCHardwareList.py", 
line 276, in save
    modules.write()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/Conf.py", line 981, 
in write
    self[key] = self.vars[key]
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/Conf.py", line 933, 
in __setitem__
    findexp = '[\t ]*' + key + '[\t ]+' + varname + '[\t ]+'
TypeError: illegal argument type for built-in operation

Local variables in innermost frame:
missing: 1
key: options
place: 0
value: {'options': {}}
self: <netconfpkg.NCHardwareList.MyConfModules instance at 84debf0>
varname: None

2.
3.
	

Additional info:

Comment 1 Phil Knirsch 2003-02-07 12:47:13 UTC
Reassigning to correct component.

Read ya, Phil

Comment 2 Harald Hoyer 2003-02-07 12:48:38 UTC

*** This bug has been marked as a duplicate of 59017 ***

Comment 3 Red Hat Bugzilla 2006-02-21 18:50:09 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.