Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77908 - text2wave script in the festival package contains a wrong path to binary.
Summary: text2wave script in the festival package contains a wrong path to binary.
Keywords:
Status: CLOSED DUPLICATE of bug 102985
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: festival
Version: 8.0
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-15 07:33 UTC by jeremy@nirvani.net
Modified: 2007-04-18 16:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:09 UTC


Attachments (Terms of Use)

Description jeremy@nirvani.net 2002-11-15 07:33:10 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021112
Phoenix/0.4

Description of problem:
The path to the festival binary in the /usr/bin/text2wave script is wrong.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. create a file 'foo.txt' and put in it "hello world".
2. run the text2wave program: $ /usr/bin/text2wave foo.txt -o foo.wav
The script fails here.

Actual Results:  The script exited warning that the festival binary could not be
executed.

Expected Results:  foo.wav should be written in .riff format.

Additional info:

# Here is a patch that fixes the problem.

--- /usr/bin/text2wave  2002-08-14 16:16:33.000000000 -0700
+++ /usr/bin/text2wave.fixed    2002-11-14 23:31:01.000000000 -0800
@@ -1,5 +1,5 @@
 #!/bin/sh
-"true" ; exec /usr/src/build/137727-i386/BUILD/festival/bin/festival --script $0 $*
+"true" ; exec /usr/bin/festival --script $0 $*
 ;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;-*-mode:scheme-*-
 ;;                                                                       ;;
 ;;                Centre for Speech Technology Research                  ;;

Comment 1 Bill Nottingham 2003-08-25 16:15:28 UTC

*** This bug has been marked as a duplicate of 102985 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:50:09 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.