Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77906 - plotting of a matrix does not work
Summary: plotting of a matrix does not work
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: octave
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-15 00:43 UTC by Dmitri A. Sergatskov
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-18 14:12:54 UTC


Attachments (Terms of Use)

Description Dmitri A. Sergatskov 2002-11-15 00:43:08 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
s=randn(n);plot(s); does not work as expected for n>7. 
(it should produce n plots, but it would produce only 7). 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run octave
2.at octive prompt type: s=randn(10); plot(s)
3.
	

Actual Results:  See 7 plots, 8 keys (legends).

Expected Results:  10 plots, 10 keys (legends)

Additional info:

The problem is with both RH packaged octave as well as with 
custom compiled the most recent version. The problem seems to 
be specific to RedHat 8.0, it does not reproduce on RH7.3 nor
on Debian systems. There is some discussion of this problem 
on octave mailing list.
It might be not a bug in octave after all but rather in gcc3.2 or
glibc/libstdc++ libs.

Comment 1 Jeff Johnson 2002-11-16 21:40:35 UTC
There appears to be a limit of 8 on the
# of plots produced using 8.0 with octave-2.1.39-2


Comment 2 Dmitri A. Sergatskov 2002-11-17 04:02:16 UTC
It is a bug. The actual bug is in internal 'sprintf' function.
To demonstrate it try:
octave:1> cmd="0"; for j=0:28 cmd=sprintf("%s, %d", cmd, j+1) endfor

Anyway the bug fixed in the CVS and in the upcoming release 2.1.40.
(To call the fact that there is only 7 plots for 8 keys "a feature" is a stretch.)


Comment 3 Jeff Johnson 2002-11-18 14:12:47 UTC
FWIW, I don't see 7, but rather 8, plots.

But I'll look form 2.1.40 down the road.

Comment 4 Dmitri A. Sergatskov 2002-11-21 07:01:37 UTC
FWIW:

The octave-2.1.40 is released, I have compiled it can confirm that the bug is gone.


Comment 5 Jeff Johnson 2002-11-24 16:24:01 UTC
Fixed in octave-2.1.40-1.


Note You need to log in before you can comment on or make changes to this bug.