Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77871 - quota command does not show grace period when hard limit is reached
Summary: quota command does not show grace period when hard limit is reached
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: quota
Version: 4.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Petr Pisar
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks: 589472
TreeView+ depends on / blocked
 
Reported: 2002-11-14 16:30 UTC by Scott McBrien
Modified: 2018-12-06 09:45 UTC (History)
5 users (show)

Fixed In Version: quota-3.12-8.el4
Doc Type: Bug Fix
Doc Text:
When a user reached the hard quota limit, the "quota" command did not display the remaining grace period (that is, the remaining time before enforcing the limits) in its output. With this update, "quota" always displays the amount of time remaining in the grace period when the user has exceeded or met their hard or soft disk usage limit.
Clone Of:
: 589472 (view as bug list)
Environment:
Last Closed: 2010-10-13 13:56:27 UTC


Attachments (Terms of Use)
"script" output illustrating problem (deleted)
2007-03-22 05:27 UTC, Wayne Pollock
no flags Details
Fix (deleted)
2010-05-06 07:59 UTC, Petr Pisar
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2010:0767 normal SHIPPED_LIVE quota bug fix update 2010-10-13 13:56:22 UTC

Description Scott McBrien 2002-11-14 16:30:41 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
When the hardlimit has been reached by a user, the quota command no longer
displays the remaining grace period.  When only the soft limit has been
exceeded, the quota command performs as expected.  If the user, who has reached
the hard limit, removes files such that they are still over the soft limit, but
not at the hard limit, the grace period returns to the output of quota.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.create a user
2.set hard and soft block quotas for said user
3.create files (maybe with dd?)
4.run quota when the hard block limit has been reached
	

Actual Results:  Disk quotas for user frank (uid 2021):
  Filesystem  blocks   quota  limit   grace  files  quota  limit  grace
   /dev/hda1   10240*   8192  10240              2      0      0       

Expected Results:  Disk quotas for user frank (uid 2021):
  Filesystem  blocks   quota  limit   grace  files  quota  limit  grace
   /dev/hda1   10240*   8192  10240   7days      2      0      0       

Additional info:

Comment 1 Bill Nottingham 2006-08-07 17:34:25 UTC
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
Please check if this issue is still present in a current Fedora Core
release. If so, please change the product and version to match, and
check the box indicating that the requested information has been
provided. Note that any bug still open against Red Hat Linux on will be
closed as 'CANTFIX' on September 30, 2006. Thanks again for your help.


Comment 3 Scott McBrien 2007-03-09 15:37:56 UTC
Steve,

Basically what I'd expect to happen is that even if the hard limit is reached,
the quota command run by a user would continue to show their current, remaining
grace period.  Currently, the grace period is shown if a user is over their soft
limit, but when they reach their hard limit the information is not displayed,
even though the soft limit grace period is still counting downward.  It would
make sense to not display the grace period if the user does not have a soft
limit set.

-Scott

Comment 4 Wayne Pollock 2007-03-22 05:27:07 UTC
Created attachment 150643 [details]
"script" output illustrating problem

This transcript on an FC6 system shows the problem.

Comment 5 Wayne Pollock 2007-03-22 20:56:33 UTC
I have confirmed this problem in FC4-FC6  (quota-3.13-1.2.3.1).  I have also
confirmed that the problem is not present if you build quota from source from
http://sourceforge.net/projects/linuxquota (version 3.14).  So I assume the
official RPM needs to be rebuilt.

Comment 6 RHEL Product and Program Management 2008-10-31 16:40:44 UTC
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".

Comment 7 Ondrej Vasik 2010-03-19 14:41:49 UTC
Patch is available at http://linuxquota.cvs.sourceforge.net/viewvc/linuxquota/quota-tools/quota.c?r1=1.15&r2=1.16 - note - just part of that patch is needed to fix the issue, in fact easyfix.

Comment 9 Petr Pisar 2010-05-06 07:59:16 UTC
Created attachment 411864 [details]
Fix

This is a patch back-ported from above-mentioned CVS link. It fixes this bug.

Comment 13 Jaromir Hradilek 2010-07-28 11:13:11 UTC
Technical note added. If any revisions are required, please edit the "Technical Notes" field
accordingly. All revisions will be proofread by the Engineering Content Services team.

New Contents:
When a user reached the hard quota limit, the "quota" command did not display the remaining grace period (that is, the remaining time before enforcing the limits) in its output. With this update, "quota" always displays the amount of time remaining in the grace period when the user has exceeded or met their hard or soft disk usage limit.

Comment 15 errata-xmlrpc 2010-10-13 13:56:27 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0767.html


Note You need to log in before you can comment on or make changes to this bug.