Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77870 - xirc2ps_cs hangs on cardctl eject
Summary: xirc2ps_cs hangs on cardctl eject
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 7.3
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-14 16:27 UTC by Need Real Name
Modified: 2008-08-01 16:22 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-09-30 15:40:11 UTC


Attachments (Terms of Use)

Description Need Real Name 2002-11-14 16:27:18 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 4.0; Agilent 
Technologies IE5.5 SP2)

Description of problem:
I updated to the 2.4.18-17.7.x kernel and now when I do a cardctl eject the 
machine hangs.  If I physically eject the card it is fine.
This previously worked with no problems on 2.4.18-10.
The log entrys just before crash are :

cardmgr[565]: executing: './network check eth0'
cardmgr[565]: shutting down socket 1
cardmgr[565]: executing: './network stop eth0'
cardmgr[565]: executing: 'modprobe -r xirc2ps_cs'
syslogd 1.4.1 restart.

one other thing is that as far as I can tell 
./network check eth0


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.do "cardctl eject" with a pcmcia ethernet card that uses the xir2ps_cs module
2.
3.
	

Actual Results:  Machine hangs ... no response to mouse or keyboardThe pcmcia 
card should have been powered down and the ethernet interface shut down

Additional info:

Comment 1 Need Real Name 2002-11-14 16:42:22 UTC
Just tried putting it into suspend mode, which powers down the pcmcia cards ... ie it does a cardctl 
eject.  But this appears to work ok

Comment 2 Need Real Name 2002-11-15 10:58:00 UTC
Scrub that last comment I'd booted using the wrong kernel
sorry.

Comment 3 Bugzilla owner 2004-09-30 15:40:11 UTC
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/



Note You need to log in before you can comment on or make changes to this bug.