Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77865 - Documentation: /etc/hosts.lpd, but in /etc/lpd.perms: /etc/accepthost
Summary: Documentation: /etc/hosts.lpd, but in /etc/lpd.perms: /etc/accepthost
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rhl-cg
Version: 8.0
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Tammy Fox
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-14 16:02 UTC by Ronny Klein
Modified: 2007-04-18 16:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-12-18 16:10:32 UTC


Attachments (Terms of Use)

Description Ronny Klein 2002-11-14 16:02:14 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i586; U;) Gecko/20020830

Description of problem:
If you want to connect a RH 8.0 box to a remote unix printer running on an other
RH 8.0 box, the documentation "Red Hat Linux 8.0: The Official Red Hat Linux
Customization Guide, Chapter 26. Printer Configuration, Adding a Remote UNIX
Printer" says:  "The remote machine must be configured to allow the local
machine to print on the desired queue. As root, create the file /etc/hosts.lpd
on the remote machine to which the printer is attached. On separate lines in the
file, add the IP address or hostname of each machine which should have printing
privileges." 

But after doing so, you are further not allowed to print on the remote printer.
Checking /etc/lpd.perms on the remote host gives you the reason: Printing is
allowed only local. You have to uncomment the follwoing line:

##   ACCEPT SERVICE=X REMOTEHOST=</etc/accepthost

Bingo! The filenames differ.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Read "Customization Guide".
2. Create /etc/hosts.lpd on the remote host.
3. Try to print.
	

Actual Results:  Permission denied!

Expected Results:  There are two possibilities:

1. Change the "Customization Guide": Inform the Reader that one have to adjust
the permissions settings in /etc/lpd.perms. Change the filename in
/etc/lpd.perms to /etc/hosts.lpd

2. Enable 'ACCEPT SERVICE=X REMOTEHOST=</etc/hosts.lpd' in /etc/perms as default.

Additional info:

Comment 1 Tammy Fox 2002-12-18 16:10:32 UTC
I have fixed this for the next release and added a docs errata
at http://www.redhat.com/docs/errata/RHL-8.0-Manual/. It should
appear shortly. Thanks for your report.

Comment 2 Theodore C. Belding 2003-01-04 20:26:32 UTC
I think the docs errata at http://www.redhat.com/docs/errata/RHL-8.0-Manual/
should read:

"In addition to creating the /etc/hosts.lpd file containing hostnames, the
following line must also be added to /etc/lpd.perms to enable sharing:
ACCEPT SERVICE=X REMOTEHOST=</etc/hosts.lpd"

Currently it reads:

"In addition to creating the /etc/hosts.lpd file containing hostnames, the
following line must also be added to /etc/lpd.perms to enable sharing:
ACCEPT SERVICE=X REMOTEHOST="
^^^^^^^^^^^^^^^^^^^^^^^^^^^^

The problem seems to be an unescaped "<" in the HTML for the page:

 <tt class="COMPUTEROUTPUT">ACCEPT SERVICE=X REMOTEHOST=</etc/hosts.lpd</tt>
                                                        ^ 
should be:

 <tt class="COMPUTEROUTPUT">ACCEPT SERVICE=X REMOTEHOST=&lt/etc/hosts.lpd</tt>
 
I haven't checked to see whether this is also incorrect in the updated rhl-cg
itself.

Comment 3 Tammy Fox 2003-01-06 20:54:05 UTC
Thanks for the catch. I fixed the webpage.


Note You need to log in before you can comment on or make changes to this bug.