Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77864 - Serious artifacts in ATI DRI rendering.
Summary: Serious artifacts in ATI DRI rendering.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks: 82776 82779
TreeView+ depends on / blocked
 
Reported: 2002-11-14 15:46 UTC by Joe Krahn
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version: 9
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-04-15 09:10:04 UTC


Attachments (Terms of Use)
GLUT example, bitmap+depth rendering bug. (deleted)
2002-11-14 15:48 UTC, Joe Krahn
no flags Details
GLUT example, line with depth+smooth bug. (deleted)
2002-11-14 15:49 UTC, Joe Krahn
no flags Details
X server log (deleted)
2003-03-04 18:48 UTC, Joe Krahn
no flags Details

Description Joe Krahn 2002-11-14 15:46:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [en] (X11; U; Linux 2.4.18-17.8.0 i686)

Description of problem:
I get serious artifacts when rendering with ATI DRI using
lines with smooth+depth, or bitmaps with depth test enabled.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Compile and run attache test programs.
2.
3.
	

Actual Results:  Very broken rendering, as if the depth buffer is getting filled
with random data.

Expected Results:  Normal rendering.

Additional info:

The distributed Mesa demo /usr/bin/aapoly also renders incorrectly.

I posted the bitmapbug example to the DRI group a few months
back.

I haven't been using ATI DRI for a long time because
it always caused system lockups. Finally, the RH 8.0 XFree86
is stable, but the rendering is still broken. So, I'm back to
compiling my own, or disabling DRI.

Comment 1 Joe Krahn 2002-11-14 15:48:03 UTC
Created attachment 85044 [details]
GLUT example, bitmap+depth rendering bug.

Comment 2 Joe Krahn 2002-11-14 15:49:41 UTC
Created attachment 85045 [details]
GLUT example, line with depth+smooth bug.

Comment 3 Mike A. Harris 2003-01-26 09:38:49 UTC
Please attach your X server log, config file, and /var/log/messages
from after a problem event has occured.

Comment 4 Joe Krahn 2003-03-04 18:48:35 UTC
Created attachment 90466 [details]
X server log

This log is actually from a different system with different hardware
and a different ATI card, but the artifacts are the same.

Comment 5 Joe Krahn 2003-04-03 17:48:34 UTC
Just tried this in RH 9. Everything works OK. Wow. This is actually
the first time in all RedHat releases that DRI ATI has worked for
my application that does mostly smoothed lines and bitmap text.


Comment 6 Mike A. Harris 2003-04-15 09:10:04 UTC
Great to hear.  Closing as CURRENTRELEASE of RHL 9


Note You need to log in before you can comment on or make changes to this bug.